Noob Dataview Query stop working

What I’m trying to do

I’m trying to simply query all notes with certain properties and those with the property “suggested” checked

Things I have tried

table as "" 
from ""
where activity = [[1 - Clients Delivery]
		and client = [[Client]]
			and type = [[Product]]
group by area

No result to show

from ""
where activity = "1 - Clients Delivery"
		and client = "Client"
			and type = "Product"
group by area

No result to show


from ""
where suggested = true

only show some notes with that property checked

Whats going on?

Everything was working today before I changed some properties name

I tried to drop dataview caches to no avail

Dataview has become so unstable since the properties release

The quality of my workflow has decreased a ton

This is incredibly frustrating

Hi @paoloap ,

Would you mind posting an example of the frontmatter of a couple of your files? That might help point us to where the problem is.


1 Like

Given a properly formatted link in your frontmatter, the query part above should work.

This query part shouldn’t work, given a formatted link in your frontmatter.

Regarding suggested, both suggested = true and the simpler suggested should work to pick only the suggested entries. Yet again, given that they’re formatted properly in the frontmatter as checkboxes.

Given this frontmatter:

suggested: true
activity: "[[1 - Clients Delivery]]"
- "[[2 - Clients Pickup]]"
nonLink: [[3 - Clients Thingy]]
type: product

You’ll get this output:

You’ll need to pay attention to the type in front of the property, in order to treat them correctly. Here is a run through of the types used in this examples:

  1. A checked checkbox, which hold the value of true
  2. A properly formatted link to [[1 - Clients Delivery]], which can be checked using equality like in activity = link("1 - Clients Delivery") or activity = [[1 - Clients Delivery]] ( My personal feeling would be to use the former, as I feel the latter could break easily with strange note names)
  3. This a list of links, and you’ll need to use some variant of contains() & co
  4. This is not a properly formatted link. In fact it’s an array holding a array of a single text element: “3 - Clients Thingy”
  5. In my example here the product is just a text, not a link, which could be checked using type = "product"

A table view of this frontmatter (and the list explanation) is:

Notice how in the third column there is one dot, indicating a list, and in the fourth column there are two dots, indicating a list with a list.

Update: Corrected typo in usage of link()

1 Like

Thanks for your response, Holroy.

I was able to fix everything following your directions.

I guess that since the introduction of properties, querying became a whole less intuitive for me.

I don’t write new queries that oftem and I tend to forget the basics

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.