Non-PDF attachments not showing on Mac

We strongly recommend you to search the forum with possible keywords before submitting a new bug report. Please also try your repro steps with third-party plugins and custom CSS disabled and see if it’s still reproducible. If it’s an issue with third-party plugins or themes, try contacting the author for help. Once you’ve done the above, delete this line.

Steps to reproduce

Save a non-PDF file to the attachments folder.
Try to link in document but doesn’t show up. Is also not in the folder system. File shows in Finder as in the right place.

Expected result

Non-PDF attachments behave like PDFs and are accessible from the attachments folder.

Actual result

Attachments cannot be linked.


  • Operating system: Mac OSX Monterey 12.4
  • Debug info:
    Obsidian version: v0.14.15
    Installer version: v0.14.6
    Operating system: Darwin Kernel Version 21.5.0: Tue Apr 26 21:08:37 PDT 2022; root:xnu-8020.121.3~4/RELEASE_ARM64_T6000 21.5.0
    Login status: logged in
    Catalyst license: vip
    Insider build toggle: on
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: Minimal
    Snippets enabled: 1
    Safe mode: off
    Plugins installed: 28
    Plugins enabled: 20
    1: Better PDF Plugin
    2: Checklist
    3: Cycle through Panes
    4: Hotkeys++
    5: Markdown prettifier
    6: Natural Language Dates
    7: obsidian markmind
    8: Outliner
    9: Quick Switcher++
    10: Recent Files
    11: Style Settings
    12: System Dark Mode
    13: Tag Wrangler
    14: Templater
    15: Typewriter Scroll
    16: Calendar
    17: Minimal Theme Settings
    18: Obsidian Enhancing Export
    19: Things Logbook
    20: Things Link

Custom theme: for cosmetic issues, please first try updating your theme to latest. If still not fixed, please try to make the issue happen in the help vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the help vault or disable community plugins.

Additional information

PDF files work fine.

PDF files work fine.

What filetype does your attachement have?
If its not a image:
Do you have Settings > Files & Links > Detect all file extensions enabled?
Obsidian will only show filetypes it can handle by default.


I did not! Thank you. I could see PDFs and PNG but that was it. I’m not sure where the setting changed because it was working fine a couple of weeks’ ago.

Thanks for your help.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.