Non-breaking space marks todo as completed

Steps to reproduce

  1. Create a new note
  2. Create a todo-list with two incomplete items
  3. Change one of the spaces between brackets to a non-breaking space
  4. Switch to Preview

Expected result

Both todo items are rendered as not completed.

Actual result

The item with breaking space between brackets is marked as completed.


  • Operating system: macOS Big Sur (11.6.1)
  • Obsidian version: 0.12.19

Additional information

On mac, breaking space is inserted with Option+Space.
At least on Swedish keyboard, brackets are inserted using Option+8 or 9. It it therefore common, for me, to (accidentally) keep Option pressed while typing 8 space 9 to get the todo brackets.

Please, open a feature request.

Sorry, why is this a feature request?

Simply because I don’t consider this a bug. This is a behavior that you would like to have but is not a bug. A non breaking space is not a regular space.

If you type Cmd-Enter, you will cycle between a bullet, a task, and a checked task. There is no need to manually type the checkbox syntax.

It even works on lines that already have content:


Thats an unusual definition of a bug. I would say it is unexpected behaviour… (You can’t see that there is a non-breaking space, it looks just like a normal space)
Just to be clear - I don’t intentionally type a non-breaking space. It just happens - by accident! (Or copy-paste)

Thanks for the tip, @rigmarole. Very convenient - I did not know that!