"No such file or directory, rename" when renaming a file by copy-pasting in the title if it has spaces

Steps to reproduce

Create a new file in the main directory of the vault
Rename the file by copy-pasting in text that is at least two words separated by a space, from a word document

It’s worth mentioning at this point that I can still change the titles by typing them in

Expected result

new file should have been properly renamed

Actual result

above image, title reverts to previous state


Windows 10 64-bit
Vault is saved on OneDrive

I think the issue here are the commas in your new filename. Does the problem happen if the inserted text does not have commas?

Not sure if the isses is in commas or the copy pasted text containtains special characters (strange whitespaces)

Yeah I was wondering that too when I was making my post. I took two words that didn’t have any special characters in them, pasting them in gave the same error, but if I remove the space it works just fine

I figured it might have been the fact that the titles were in italics, so I took two random words that didn’t have anything going on from the document. Same result

If you are coping from a PDF, things cat get tricky because characters and spaces may look normal but are infact encoded differently.

If you copy one word from this document does it work?
If you copy two words and manually remove the whitespace, does it work?
If you copy two words and manually remove and add the whitespace, does it work?

It’s a docx that was fully edited on the same device and hasn’t been converted as far as I’m aware of. It’s saved on OneDrive though, so maybe there’s something going on there.

Eitherway, pasting in a single word works
Removing the space works
Removing and adding a space also works

I messed around a bit more and it’s definitely Word being weird about its spaces. If I type in two words with a whitespace and copy-paste it works fine
However if I save the docx locally, close it, and reopen it, the error occurs

1 Like

I am not sure if you set word to save your documents with some non-standard encoding. If you send us the word file (on discord, or one drive link via PM), we can see if we can circumvent this weird character.

I’ll hop onto the discord real quick. I haven’t messed about with the settings though, but it’s an office 365 installation from my campus, so maybe they did something.