No return after creating a link using Spanish ISO keyboard MacOS

Steps to reproduce

  1. From U.S. keyboard, switch to Spanish ISO keyboard. ⌃Space Bar
  2. Create a new note. ⌘⇧N
  3. Type the title.
  4. Type something for notes.
  5. Create a link. [[]]
  6. Press tab and down arrow to choose note [[Note]]
  7. Press tab and down arrow to choose heading [[Note#heading]]
  8. Press | and type a new display name [[Note#heading|note]]
  9. Press return more than once.

Expected result

Pressing return multiple times should create new lines.

Actual result

Only one new line, even if I keep pressing return more than once.


  • Operating system:
  • Debug info:
    Obsidian version: v0.13.23
    Installer version: v0.12.10
    Operating system: Darwin Kernel Version 21.3.0: Wed Jan 5 21:37:58 PST 2022; root:xnu-8019.80.24~20/RELEASE_ARM64_T8101 21.3.0
    Login status: logged in
    Catalyst license: none
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: none
    Snippets enabled: 0
    Safe mode: off
    Plugins installed: 0
    Plugins enabled: 0


Additional information

can you post a screen recording of this happening?

Of course. Thank you.

do you get errors in console? cmd-opt-i?


does this happen in the help vault?
Does this happen with US layout or there is something special with Spanish ISO?

Does it happen in source mode?

Yes. It happens in the help vault.
No, it does not happen with US.

How do I get to source more?

I added another video to the folder using the help vault.

IF you close and reopen the document, does enter work?
can you attach here a copy of file where enter is not working?

TO try source mode, use the bottom option

It only happens using live preview.

I have the feeling that when you use the Spanish keyboard, you unwilling enter some weird character or you trigger some dead key behavior.

I have had other user press alt-space instead of just space and this was creating problems in bullet lists.

At 0.32sec the parsed link already looks odd (the brackets have different colors).

Thank you for taking the time for testing!

So these are the keys that I am typing.

command + shift + N
Typing the title
control + space bar
Typing something
Typing link.
option + [[
Down arrow (selecting Title bar)
option + 3
Down arrow (selecting Window management)
option + 1 (to get | )
Space bar ******* I think the bug is here ******
Typing the new display name
then it stops creating a new line.

Never mind. I think it is when I type ``and then delete it.

Yes, so I want to get the brackets [[ , but I forget to press option then [[.
That is why I get ``. I then delete it and type the brackets.

I think that is what is causing the bug.

If you don’t do that, it works?

Ok so this is another weird dead key problem.

So I tried it with the US keyboard by purposefully pressing the backtick ``.
I delete it and type the brackets [[
I do the usual
down arrow
Title bar
Shift + 3 to get #
down arrow to select Window management
Shift + \ to get |
Type a new display name
return again and I get the bug.

By US keyboard, you mean the the standard one or the international one? Post a screen recording.

The keyboard that comes by default.

I don’t really know why I can’t recreate them. I tried to recreate the bug using the US keyboard, but I couldn’t.

Here is another video recording using the Spanish ISO, which does recreate the bug.