No link to notes with "05" in title

Once you’ve done the above, delete everything above this line.

Steps to reproduce

I have a note named “(2022-05) xxx”, but it is not in the local graph view when I’m on a page that out-links to the note. The note is existed, and I am sure when I opened it, I could see all the out and in-links of this specific note in the local graph view. I tried the following:

  1. Create a blank note, insert the link of the note - not working
  2. Change title to “2022-05” - not working
  3. Change title to “(202205) xxx” - works
  4. Change title to “(2022_05) xxx” - not working
  5. Change title to “05” - not working

So what’s wrong with “05”??? :smiling_face_with_tear:

Expected result

I expect to name my note “(2022-05) xxx” and can still see the other notes link to it in the local graph view.

Actual result

Actual result is that I must change my title to make sure that “05” is not in the title, or not with “-” or “_” adjacent.


  • Operating system: Windows 10 Home
  • Debug info:

Obsidian version: v1.1.9
Installer version: v1.1.9
Operating system: Windows 10 Home 10.0.19044
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: Minimal v6.2.0
Snippets enabled: 1
Restricted mode: off
Plugins installed: 3
Plugins enabled: 3
1: Icon Folder v1.5.1
2: Style Settings v0.4.12
3: Minimal Theme Settings v6.2.0

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

  1. Have you tested this in the Sandbox help vault?
  2. Test this with Restricted Mode turned on, and default theme. No CSS snippets.

Until you do this, I’ll move this to Help.

  1. Check your Local Graph settings. (Gear in the top right corner of the graph). My guess is you put something like “-05” in the search bar. Which would filter out any results that matched 05.

Thank you very much! Problem solved! I checked my local graph settings and I found that I was using "-path:“05"” to exclude a folder. But I still don’t understand why pages were affected. As I put “-path” in the search block, it should only exclude folders I think.

I don’t know exactly, but I assume it’s something to do with the quotation marks. Your syntax might be off a bit.

Did you type that from memory or copy paste it? Maybe there was a space in there, that changed the operator. Or something like that.

Oh, testing, the path operator searches inside the entire path, including note names. So if you want to exclude a folder, you should maybe include a portion of the slashes /05 or a root folder or the whole folder name, to make it more specific. (There are likely fancier ways to do it properly.)

Thank you for the suggestions! My folder was named something like “05 xxx”. I now exclude folders by typing in the full name of the folder to avoid the problem. :grin:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.