No embracing for * and _ in code blocks

I have a hard time finding a way to describe what I want in few words.

What I’m trying to do

Usually when you type _ or * you get _<cursor>_ or *<cursor>*. I find this very useful unless I am in a codeblock (three backticks before and three backticks after) or monospace/unformated (one backtick before and one after).

I would like to disable this behaviour, but only for * and _ in code sections, but not in general an not for parentheses, braces, and brackets.

Things I have tried

The issue I have is that I have trouble naming the feature to search for it “embracing _” or “closing *” yields nothing on

You can find the setting here: Settings -> Editor -> Auto pair markdown syntax
Not specific to code sections though.

1 Like

The words I was looking for: Auto pair
Thank you!

I marked it as solution, even though it technically is not.

I will open a feature request to only disable certain auto pairinings in certain situations.

Make sure to search first — I think there might already be a request for this.

1 Like

Which is why I did not get around to opening one yet. There are so many results for “auto pair” that I did not get around to looking through them.

There is this one that goes about it in a more dynamic manner, detecting if it is a code block or not: Make Obsidian's behavior on codeblocks dependent on their type

A closed bug: Auto Pair is active in a code fence block

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.