No data, at all, showing in the Zotero Data Explorer bar

What I’m trying to do

I recently started to cleanup all my pdfs and importing them into Zotero which currently has over 17,000 documents. When my library was small, say less than 3,000 items, I was able to successfully import my notes and such from Zotero into Obsidian using Better Bibtex (Zotero) and the Zotero Integration plugin (Obsidian) via the data explorer bar (image). In the smaller library I would see a list under the bar of relevant papers to choose from

Now, as you can see in the image, the bar just continually spins and I never get a choice of papers to appear and select from. The only thing that has change is the number of items in the Zotero library.

  • Has anyone else had a similar experience?
  • Is this an artifact of a huge library? (3k vs 17k items)
  • Is there any thoughts on a solution?

Things I have tried

I have tried various options to solve this with no success including

  1. Updating both the Zotero and the Obsidian plugins to the latest versions.
  2. Downgrading the Better Bibtex plugin to V6.7.96 per the mgmeyers Obsidian plugin GitHub issue No data received in Data Explorer #257.
  3. Exported my library to a Better Bibtex BIB file and a Zotero RDF file which I placed in the plugins folder.


  1. Made a Github issue with mgmeyers No data, at all, showing in the Data Explorer bar #299

Was about to advise.

I’ve had experience with the Zotero Integration plugin.
Question: do the selected pdf’s have annotation notes? Probably you know how to use the plugin. You even went so far as to write the full file name to make sure it will be caught.

The setup worked well when I had 3K items in the library. As shown in the image, the whole title is typed out like the paper beside it.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.