New window: no autosuggestions when using tags or double brackets

What I’m trying to do

Since Obsidian introduced the ability to open new windows, I find that new windows (and tabs in new windows) lack a couple of my favourite Obsidian features:

  • Entering [[ doesn’t show autocomplete suggestions
  • Entering # doesn’t show autocomplete suggestions

Both of the above points work in my main/original Obsidian window and tabs in that window, but not in new windows and tabs that belong to those windows.

I guess this is by design, but I’d love to see the functionality for all windows.

I’m using the latest insider build of Obsidian (v0.16.3).

Sounds like a bug to me. Why do you think it’s by design? (I’m not on the Insider builds.)

I guessed the behaviour is by design because it’s been there since when the ability to open new windows arrived. This could absolutely be a bug. I checked the forum for bug reports and other kinds of posts regarding this but found nothing; I (perhaps foolishly) assumed that others would have reported about this being a bug before me.

That’s true, it’s surprising that a bug that interferes with such a core feature wouldn’t be reported yet. Maybe something in your setup is causing it — do you see the same problem in the sandbox vault (found in the help menu)?

Thanks for your help. I can’t find the sandbox vault; I can only see these options in the Help menu:


Sorry, it’s in the other help menu (I know, I know), in the left edge of the app, near the settings gear.

(We should prolly file a feature request to add the sandbox vault to the menu bar help menu…)

Thanks! I didn’t know a sandbox vault existed until now! :slight_smile:

Autocomplete works for me in the sandbox vault, both for double brackets and tags.

Aha! So the problem is probably a plugin — maybe one that hasn’t yet been updated to support extra windows.

Plugins don’t update automatically, so if you haven’t been updating them, go to Settings > Community Plugins, click “Check for updates”, apply them, and restart Obsidian.

If that doesn’t fix the problem, you’ll need to figure out which plugin is the problem. If there have any obvious candidates, try turning them off one at a time (restart Obsidian each time to make sure they fully unload). If you have a lot of plugins to check, you might want to use the Divide And Conquer plugin to help investigate.

Oh, thanks a LOT for your help! All plugins are updated, so I’ll check them all later today to try and find the problematic one. Also, thanks for suggesting the Divide And Conquer plugin. I’ll report back.

@CawlinTeffid : thanks to the Divide And Conquer plugin, I did this:

  1. Disabled all plugins
  2. Reloaded Obsidian
  3. Tried to use [[ and # in the main Obsidian window. Both work
  4. Tried to use [[ and # in a new Obsidian window. Neither work

In other words, it seems like the behaviour is not due to a plugin. :confused:

Oh! But it worked in the sandbox vault? Or did you not try it in a new window in the sandbox?

Autocomplete works for me in the sandbox vault, both in the main window and in new windows (and tabs) as well.

Autocomplete doesn’t work for me in my regular vault.

I just tried to open another vault that I have, one that I’ve created, and autocorrect works on that vault, both in the main window and in new windows (and tabs).

Seems like something is wonky with my main vault, then! Hmm. I wonder if there’s some setting somewhere that messes something up. I’ve used this vault for just over a year now.

Strange! Yeah, check your settings. You could also try changing your theme, tho I don’t see why that would make a difference.

1 Like

Thanks, I actually tried changing my theme but to no avail! :frowning:

I might try and create a new vault and just rebuild the plugins and vault settings from scratch.

I’ve solved my problem by creating a new vault and copying all of my old stuff to the new one. This is what I did:

  1. Created a new vault.
  2. Copied all file contents from the old (non–functioning) vault to the new one.
  3. In the new vault, I manually installed all community plugins that were used in the old one. I enabled and configured them exactly as in the old vault.
  4. In the new vault, I added and activated my preferred theme.
1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.