New plugin: macOS-like alt+(shift)+↑ and alt+(shift)+↓ keyboard navigation

It does what it says on the tin:

Find it in the in-app plugin gallery or on GitHub.

1 Like

Thanks, @ryanjamurphy! I’ve been looking for this. Can you confirm that this works with the Sliding Panes plugin? It seems to only work on the left-most pane when I have multiple panes open. Am I missing something?

It works for me with multiple panes open, and with sliding panes enabled to boot.

I wonder if there’s a conflicting shortcut for you. There are some shortcuts that help navigate between panes—try filtering the hotkeys preferences for “pane” to check.

Version 1.1.1 resolves a minor error reported on launch. (The plugin was checking for an active editor when, obviously, Obsidian was only just waking up.)

Installed into 0.9.16 on a Mac, and although the navigation works now I can’t type anything! Disabling the plugin gives me back the ability to type, so I’m pretty sure it’s the plugin. Any ideas?

Odd, I’m using it myself with no problems. Are you on Big Sur?

Yes, I am on Big Sur. It is really odd, I can’t quite figure it out. Haven’t tried it with all other plugins disabled as yet (away from my computer at the moment), but I’m wondering if it’s some weird interaction thing. Playing with quite a few plugins at the moment.

Will let you know once I’m back home and have done a bit more testing.

Interesting. I just experienced the same—or at least, similar—thing. I could navigate up and down, but couldn’t enter text.

However, I disabled this plugin and the problem persisted.

Reloading the app made it go away…

Something to watch. :thinking:

See the first bug fix in 0.9.17—probably was this issue!

1 Like

Came here to post the same thing :slightly_smiling_face: Yep, I think so!

Thanks for this @ryanjamurphy — this is such a critical “feature” for those of us who naturally rely on this behavior when editing text.

1 Like

Hey @ryanjamurphy, love the work that you do!

I’ve noticed a bug when selecting text using this plugin with multiple text cursors: when selecting multiple paragraphs using multiple cursors and pressing Shift+Alt+Up/Down, only one of the paragraphs gets selected, or a better description would be that the selection for the other paragraphs disappear:

ezgif.com-gif-maker

1 Like

I find it weird that multi-select works at all! Still, I’ll look into the shift problem. (Submit an Issue to GitHub if and when you get the chance, please!)

1 Like

I’m having a hard time following what this does. I know you said look at the video but honestly it moves to fast that I lose track of where the cursor is and which up/down sequence you pressed. Best I can tell is you are trying to suggest it maintains cursor position when holding shift and go up or down. Then alt and shift select the whole line.

@3mbry0 thank you for reminding me about multi-cursor. I forgot all about it since I haven’t had a reason to use VS Code much these days. nice to see that it is present here in Obsidian as well

MacOS has keyboard text navigation in most apps. This restores the alt/opt key functionality of that navigation in Obsidian. That’s all.

I guess my confusion resides in if it has benefits for non mac users and if so how.
For instance I am a big proponent of the compose key and use addons in Windows to support it such as wincompose and espanso. Linux thankfully has an option to designate a compose key built in.

Thanks for the plugin! It was driving me mad. These are the kind of details that make Obsidian a better “Mac citizen”.

1 Like