New Plugin: Journey - Find the story between your notes

Hi @EhuddRomero, that sounds great! Makes me happy to hear you’re having fun :slight_smile:

I’ve added your two ideas to my backlog and with a few more ideas I’ll create a new poll like the one above soon.

Thanks so much!

Great plugin, Alexis!
1 new idea is an option to input the starting value, then click “I feel lucky”, as a quick way to query new (or not new) notes for existing link-ability.

1 Like

Hi @EhuddRomero, that sounds great! Makes me happy to hear you’re having fun :slight_smile:

I’ve added your two ideas to my backlog and with a few more ideas I’ll create a new poll like the one above soon.

Thanks so much!


I’m testing the plugin since yesterday and it is unable to find any path. I tried it with notes directly linked, some notes apart and notes realy far apart, but it is just showing “Searching…” and nothing happens for hours (let it search for 3h straigt)

These are the other plugins I use, perhaps there is something blocking “Journey” from doing it’s job?
Screenshot 2021-02-04 100502
I tried things like restarting and reinstalling but nothing changed. Do you have an idea?

1 Like

Great plug-in @akaalias. I do have a peculiar behavior I have not been able to figure out. Often, when I search a connection, the connecting note comes back as a ‘#gid’. I don’t have a tag in my vault labeled as such. Any ideas what might be happening?

1 Like

Hey there!

Sorry if I’ve not responded to you right away this week – I think about making the plugin better and work for you a lot – But since last Friday I’ve had to take care of a family member with post-op complications (non-COVID though). So, if you don’t hear from me right away, that’s the reason.

@Katlar - That is weird and it shouldn’t take more than a few moments anyways. I don’t see any reason why plugins should interfere but can you do two things:

  1. Disable the other plugins and run a search again
  2. File a quick issue on github:

@jeffk8900 have you run a full text search that this tag #gid really doesn’t exist anywhere?

Please also file a quick issue on github so I can keep track of this:

Thank you!

I just did the full text and it is picking up the string #gid which is part of a google sheet url that I use for keyword tracking. The url is…/edit#gid=0&organge=E1. So the #gid is part of the location match for the sheet. Not sure why it is being picked up.

1 Like

Got it – That is the reason (the parser thinks this is a tag as well), thank you for finding. I’ll include this in the next release!

PS: If you find more oddities, please also create an issue on Github (Makes it easier to keep track)


1 Like

Hi, I tried plug-in
Must admit the idea is great and can create new thinking
However, I do not have a large map at all

And I get more than one result that the two notes may not be on the same network
However, they are both on the same network and share tags, I can not point to the problem …
You have an idea?

Always take your time for the family! Hope everyone is well soon!

I filled the issue on github but honestly didn’t really know what to include since I am a 100% user and don’t know anything about coding. I mentioned everything, I think could be a factor. Otherwise, I can provide you more information if required :slight_smile:

Thank you for the (normally) really useful tool :slight_smile:

1 Like

Hi Dana! Thank you for your response. To investigate: Can you please create an issue on github and include the two files that should be on the same network?


Hi all!

Based on your amazing feedback and ideas, you now have the following new features available. Go and update your current version for the following:

New Features :tada:

Exclude Folders Feature

Allows you to set a list of comma-separated folder paths (e.g. “Daily Notes/, Attachments/”) that will be excluded during your search.

Auto-complete Search Feature

Search your starting and ending notes by simply starting to type in the name.


Reporting issues

Please use to share bugs and issues you find!

@ShaneNZ and @Katlar – Can you install this release and let me know if your issues persist?


I’ve created a public backlog which will allow you to see the progress on features. Prioritisation will come from voting in the group and at my own discretion.


That’s great ! Thanks you !

1 Like

This is amazing work, thank you so much, really enjoying it. One feature that didn’t seem to make it was a way to “buy you a coffee”. It’ll be great to be able to support this work moving forward!


@akaalias, need some help getting started with the Plug-in. The underlined prompts do not give me any option for selecting Notes, as the video shows. What am I doing wrong? As you can see from the circled items at the bottom, I have everything turned on in the selections.

Did you update plugin and restart obsidian after ?

Yes, a couple of times.

I’m using an Apple M1 MacMini, Big Sur.

The latest update works a bit differently than the version in the video - just select one of the boxes and start typing. It’ll give you suggestions of existing notes after the first three characters.

1 Like

Issues fixed! :partying_face: Nice work @akaalias!

1 Like

How did I miss that. Thanks much!!!

1 Like