Mysterious Inbox Vault on iOS that causes Obsidian to hang

What I’m trying to do

A vault appeared in my list of vaults called “Inbox”, that I did not create. Naturally, I had to figure out what that was, so I tapped on it to open it. And now I can no longer do anything in the Obsidian app on my phone. It is stuck as shown in the screenshot above, and clicking Reload does nothing but recreate the error immediately.

Things I have tried

This is essentially the same problem as here, but that one was for a test version of the app, and there was no resolution except to install a different version. Mine is the latest version from the App Store.

I have used the Files app to try to find this Inbox vault, and it does not exist in the Obsidian folder in iCloud or the one in “On My iPhone”. It was suggested that it is a hidden folder, because that user could access it from their computer when connected to their phone. I don’t have access to a computer right now, but in any case, they were not able to resolve it by deleting the hidden folder, and so I’m not sure it would help me either.

I am guessing (?) that a hidden system folder called Inbox somehow got created in the iOS obsidian folder, perhaps because of some kind of behind-the-scenes magic in iOS, and then it appeared in the list of vaults I could open, but Obsidian does not have permission to actually write to the hidden system folder, and so it just keeps trying and failing to create a .obsidian folder inside of it?

Seems like you are handy with comp stuff. So download the Taio app where you can access/see hidden (dot) folders (Files on iOS cannot) and do some cleanup.

1 Like

I forgot to mention that I tried to use FE File Explorer to see it, it supposedly has an option to show hidden files, which I turned on, but there is no Inbox folder I can find. However, it also does not show the .obsidian folder in my vaults, so I don’t trust it. I just tried downloadong Taio, and it’s the same, it does not see .obsidian in my vaults, or any Inbox folder. However, in both cases they seem to only access their own app’s local sandboxed folder “directly”, whereas when I go look for the Obsidian folder, both apps appear to do so using the Files app interface, as if it’s a separate API they are using to access folders outside of their local sandbox. So I am not able to see an Inbox folder, but thanks for the suggestion, and please let me know if you are able to see the .obsidian folder (for example) in your iCloud or “On My iPhone” vaults on iOS, and if so how.

(If you can, save a backup or copy first.)

That other thread didn’t say they reinstalled a different version. Just that they re-downloaded. So maybe they re-downloaded the same version.

Maybe uninstalling/reinstalling would help. But I don’t know. I’m just throwing out a guess.

I seem to remember Taio didn’t need an extra setting for hidden folders to be seen – I use Filza (JB) now.
I was using the OnMyiPad location. Don’t know about the other one but should be ok.

And yes, I forgot to mention, copy your md and config files to somewhere safe.

Taio appears to have two “On My iPhone” locations, one is within its own sandboxed directory, where I only have access to two onboarding markdown files. I was able to create a third one called, and that shows up just fine.

Separate from that it has a “Browse Documents” “folder”, which takes me to the Files app interface and allows me to see folders for all of my apps, including Obsidian, and if I use that interface to browse to the Taio/Editor folder, that third file does not show up.

Thank you, that’s a good point, and I was hoping to avoid doing that (unless I knew it would work) because I’m afraid it might take some time to get things set up the way they were (not sure though, because most settings are in the .obsidian folder, so maybe it won’t be too bad).

In Taio you go to Added Locations, hit plus sign, and navigate to Obsidian, either on iCloud or local.

Your vault settings should all be in the .obsidian folder. Hotkeys, plugins, appearance, layout, etc.

The app data, I’m not 100% sure, especially on mobile, but it stores things like File Recovery snapshots, I think (which you might not want to lose), and the list of open vaults (so you’d possibly have to browse to open your vault again).

Is see, that worked for allowing me to see the .obsidian folder, thank you! However, I already did back up everything and reinstalled Obsidian, then re-synced my vaults, so if there is any hidden Inbox there now, I think it got blown away when I deleted Obsidian (in other words, there is still no Inbox folder I can see in Taio). My settings for all three vaults I have weren’t being synced, so I’m setting up my plugins and settings again now! Thank you for your help! I probably should have been more patient to figure out if there really was a hidden Inbox folder there somewhere, but I also am trying to get other things done today, so didn’t want to get bogged down with this any longer. But thanks for introducing me to Taio, that may come in useful going forward, if I need to troubleshoot something on my phone again!

Oh, right, I did back the vaults up (separately from the Sync server), so even though I wasn’t syncing the settings before, I should be able to copy the .obsidian folders back into the three vaults I have (which I restored via Sync). Thank you!

That inbox thingy was either a Siri Shortcut you downloaded or maybe a markdownify bookmarklet.

Oh interesting, I do have a couple of Shortcuts I tried out with Obsidian a couple of days ago, I guess I will take a close look at those. The Inbox appeared to show up long after I used those, but it definitely sounds like that is a potential culprit. Thanks for the tip.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.