My obsidian community plugins have a problem

Description

When obsidian automatically upgraded to version 0.15.6, my obsidian had a problem with plugins. Each time I opened the app, it says “An error occurred while loading Obsidian. Typeerror : Cannot read properties of undefined ( reading ‘url’)”

Things I have tried

  • reload the app (it went the same way as above)
  • reload app in safe mode (it went successfully into my vault)
  • turn off restricted mode, update all community plugins in my obsidian and reload the app (the error occurs again)

What I’m trying to do

Well, obviously I’m trying to solve this problem. Can I load obsidian properly with safe mode off???

Is there any additional information in the Developer Console (open with Ctrl+Shift+i on not-macOS and Cmd+Shift+i on macOS, then click the “Console” tab) when you get the error? If you see an error message (often in red) in that console, on the right side of the message it may say which plugin is having the issue. If the messages in the Console are confusing, feel free to post them (including that right side!) and maybe folks here can help.

Ohh, yes there is.

Uncaught TypeError: Cannot read properties of undefined (reading ‘indexOf’)
at Object.match (plugin:ProxyGithub:6:29)
at matchUrl (plugin:ProxyGithub:23:18)
at EventEmitter.window.require.ipcRenderer.send (plugin:ProxyGithub:158:13)
at C:\Users\my_account\AppData\Local\Obsidian\resources\app.asar\[email protected]\remote\dist\src\renderer\remote.js:15:32
at FinalizationRegistry.cleanupSome ()

And That’s where the problem is (the third line):

let include = [
    {
        match: (url) => url.indexOf("/releases/download/") >= 0
        , to: (url) => url.replace("https://github.com/", "https://download.fastgit.org/")
    }
    , {
        match: (url) => url.startsWith("https://raw.githubusercontent.com/") >= 0
        , to: (url) => url.replace("https://raw.githubusercontent.com/", "https://raw.fastgit.org/")
    }
    , {
        match: (url) => url.startsWith("https://github.com/") >= 0
        , to: (url) => url.replace("https://github.com/", "https://hub.fastgit.org/")
    }
]

Do you have a plugin called “ProxyGithub” (or something similar)? That would be the plugin to look for and disable. You can also perhaps post an “Issue” at the plugin’s repository.

Problem solved. Thank you scholarInTraining.
ProxyGithub helps me browse community plugins in China. I need it only when I need to install new plugins. So there is no need to keep it open every time.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.