Multiple errors that started happening at the same time

What I’m trying to do

I was just typing notes and then an error popped up saying Failure to save

Things I have tried

  • I ran the Remotely Save plugin in order to backup my files, however this failed with the error EBADF: bad file descriptor, write at eval (plugin:remotely-save on the file I was working on along with some screenshot images from yesterday, which were also in this file.
  • I checked on my phone and everything works perfectly there. Just the desktop version is having problems
  • I uninstalled and reinstalled Obsidian
  • I deleted the backup file, and also the copy of it on my desktop, and then reuploaded from my phone (which had the file working) to the cloud, and then tried to download it, but that failed saying EBADF: bad file descriptor, write at eval (plugin:remotely-save again, on the same files.
  • I tried making a new version using QuickAdd, but now all of sudden QuickAdd says the template does not exist.
  • I opened the template file to double check, and it loaded empty, then after a minute or two, loaded the template.
  • Tried running the quickadd plugin again to create a new version of the notes I was working on using the template I had open and it still gave the error saying template does not exist
  • I tried updating my plugins on desktop but it fails to update any of the plugins whether I click Update All or Update on each one. These are the plugins awaiting update on desktop: Admonition, Code Editor Shortuts, Emoji Toolbar, Full Calendar, Metadata Menu, Notion Like Tables, Obsidian Columns, Projects, Quickadd, Tasks.
  • I tried updating the plugins on my mobile and that works just fine, all plugins were updated.

So only my desktop version for some reason is having problems with accessing/writing files and updating plugins.

I am on Windows 10. Current version of Obsidian is v1.2.8. Installer version is v1.2.8

Is your disk full?

Are you using some kind of cloud storage?

It isn’t. I am using a cloud storage but that isn’t full either. The EBADF: bad file descriptor, write error (which is my biggest problem) I get happens even when doing things unrelated to the files, like when trying to update plugins for example.

The solution here solved my problem

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.