Multiline footnotes [SOLVED]

I would like to include footnotes in my text to explain more details, this would mean I would have a footnote with an unordered list and one with a few lines of quoted text.

# This is a test

- some text here
- some more text here [^fn2]
- and yet more text

| col1 | col2  |
| ---- | ----- |
| row1 | row12 |
| row2 | row22[^fn1] | 

[^fn1]: extra explanation which don't fit in the table:
- item1
- item2

[^fn2]: quoted text:
> line1
> line2

results in

The footnotes are split in the first lines and the rest is treated as regular text. I’ve added colored boxes to see how they belong together.

Is this a bug or default Markdown behavior? If the latter, does anyone have an idea how to solve this problem?

Have you tried indenting the multi-line text? It might also depend on whether you have strict line breaks enabled or not.

I’ve tried indenting, which does put the lines in the actual footnote, but they are no longer rendered as list and quotes, i.e. the plain markdown text is shown.

Strict line breaks on or off don’t matter. When indented and Strict line breaks is on, the line breaks are removed and the indented lines are squashed together on one line.

I think I got this to work with indentation:

Raw text

# This is a test

- some text here
- some more text here [^fn2]
- and yet more text

| col1 | col2  |
| ---- | ----- |
| row1 | row12 |
| row2 | row22[^fn1] | 

[^fn1]: extra explanation which don't fit in the table:
	- item1
	- item2

[^fn2]: quoted text:
	> line1
	> line2

@macedotavares How did you get the footnote to start in the first column? When I enter a footnote, it indents by itself and there is no way to remove the indent.

I using the stock theme.

Never mind. I figured it out: just 1 tab indent. Thank you!

It would be neat though if the font would be equally small on all lines even in edit mode, not just preview mode. Currently, no matter what you do, if you put it on another line, tabs/no tabs, the font is of standard size, not footnote size.
See screenshot

1 Like