Multiline block quote doesn't render correctly in Live Preview (indented first line)

Steps to reproduce

  1. Type a multiline block quote as follows:
>First line
Second line
  1. Allow Live Preview to render the formatting.

Expected result

In Reading Mode the above text would render as a multiline quote:

Actual result

Live Preview doesn’t handle the lack of a > character in the second line correctly and doesn’t apply the expected padding, making the fist line appear indented.

image

Environment

  • Operating system: MacOS Monterey 12.0.1
  • Debug info:
    SYSTEM INFO:
    Obsidian version: v0.13.14
    Installer version: v0.12.12
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: none
    Snippets enabled: 1
    Safe mode: off
    Plugins installed: 11
    Plugins enabled: 9
    1: QuickAdd
    2: Periodic Notes
    3: Music notation
    4: Templater
    5: Day Planner
    6: Calendar
    7: Recent Files
    8: Admonition
    9: Dataview

Additional information

This isn’t an issue when directly entering text into a note as Obsidian automatically prepends every carriage return with a > once a block quote is started. However copying text from elsewhere or editing the existing text non-linearly creates a problem.

I make use of block quotes in markdown (not only in Obsidian) extensively and it’s always felt a bit janky regarding how it handles line breaks and multiline text, so it may be that having a > character on every line is the “correct” way to format things anyway. Nevertheless I don’t always want to have to do that, particularly if I’m copying out the quote as plaintext somewhere else, or opening my markdown file in an editor less efficient than Obsidian where removing the quote formatting from each line might be tedious.

thanks