Multi-level ordered lists in read mode require 4 (or more) spaces

Steps to reproduce

Set Settings->Editor->Tab editor size to 2.
In a note insert:

1. a
  1. b

Expected result

Either

  • delimiter based indentation
  • fixed with indentation using Settings->Editor->Tab editor size spaces as an indentation level.

Actual result

  1. a
  2. b

Environment

  • Operating system: Ubuntu 22.04
  • Debug info:

SYSTEM INFO:
Obsidian version: v1.1.9
Installer version: v0.15.9
Operating system: #64-Ubuntu SMP Thu Jan 5 11:43:13 UTC 2023 5.15.0-58-generic
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on

RECOMMENDATIONS:
none

Additional Information

The behavior for 4 or more spaces is according to delimiter based indentation, but if the number of spaces is higher or equal to 8, the item is not recognized as a list (grey numbering, correct indent, automatic increment). In edit mode layout changes at 7 spaces, but list related features such as creation of new items on Enter still work regardless of the number of spaces.

I just realized that it works for 3 spaces and that it conforms to CommonMark. It still is confusing and inconsistent with unordered lists, so I’m not sure whether this behavior is actually desirable only due to the fact of being consistent with CommonMark.