MP3 files outside vault no longer play in Audio Player

What I’m trying to do

Prior to a recent Obsidian update (not sure which) I was able to play MP3 audio via the Audio Player plugin.
This no longer works.
I have not changed any of my notes and links.

Things I have tried

The obvious think to help diagnose would be to revert to an earlier version of Obsidian but I don’t seem to be able to do this. I tried to go back to Obsidian.1.1.16 but still ended up with the latest version (Obsidian.1.2.8)

The code that works (used to check the Audio Player still works) is

![[Brigg Fair - Joseph Taylor.mp3]]

The code that fails (generated by Obsidian) is

![Brigg Fair - Joseph Taylor.mp3](file:///C:%5CUsers%5CUser%5CDropbox%5CFolk%20MP3s%5CJune%5CBrigg%20Fair%20-%20Joseph%20Taylor.mp3)

To be clear the latter played as expected but now does not. Also while the files and vault are held in my Dropbox, external picture files display properly

I believe that the issue is Obsidian not being able to access the external music file as the playback slider shows orange in the working player and is empty in the failing one, as shown below.

I think this is probably a change or bug in the way Obsidian and Audio Player exchange data but I’m somewhat out of my depth in delving into the goings on.

Fair winds
chris lawley

The native audio player look like this:

Two community plugins I saw with audio in their names don’t seem to look like your screenshot. I had never done it before, but just tried to embed an externally linked mp3 in Obsidian 1.3.2 and 1.1.16. All I get is a broken link icon (no plugins installed).

I’m curious as to where that player interface is coming from. Can you link to that plugin so we can have a look?


Apologies for the delay in getting back t you. Stupid actuality getting in the way

The plugin is “Media Extended”
I installed it early on in my Obsidian career not knowing there was a native player.

The file link is created by Ctrl+Left clicking the file and dragging into an Obsidian page.

Now the annoying bit.
I just tried linking a different file (on my D drive) and that works
sooo I tried re-linking the failed file and that worked
but the failing code is still failing

I thought that there would be something different in the code buuut
no the two are identical except that the non-working player has no empty line before it.
Inserted a blank line and it sprang to life [FX: Much gnashing of teeth]

Looking at all my other similarly linked files and they are all now working with no action taken by me.

I notice that the Obsidian version is now 1.3.5 so I’m giving Obsidian a Hard Stare - I have no other explanation.

Thank you very much for your interest.

Fair winds
chris :- )

I too get a broken icon in EDIT mode but it switches to the player in READING mode

chris :slight_smile:

Interesting! Obsidian 1.3.5 introduced a requirement to have a blank line before tables — I wonder if that somehow spilled over?

But even if the change was on Obsidian’s side, I’d recommend posting an issue about it on the plugin’s GitHub.


I do use tables but (happily) they do have preceding blank lines
They break if there’s no empty line - good to learn this.

It has no effect on the player however (which now works for no obvious user generated reason)

Given that the player now works as I expected I don’t think it worth raising a ticket(?) in the plugin’s GitHub for the moment.

chris :slight_smile:

Oh, yeah, I missed the part about all the other instances suddenly working. Computers! What a wonder they are.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.