Monospace font with korean characters (or unicode characters in general possibly)

What I’m trying to do

I was making a table containing some words in korean, and realized I was not managing to align it properly. Even the plugin I installed (Advanced tables) was not aligning it correctly and gave something like this.


If I copy that same text and paste it on vim or any terminal environment I get this:


It is correctly aligned!

It seems that the korean characters should be taking the space of two ASCII characters in the monospace font, however for some reason in obsidian, when using a monospaced font, the korean characters are downsized. I’m wondering if this is some css issue or just a setting I haven’t been able to find.

Things I have tried

I tried modifying the fonts in the settings menu. I set the font to basically every monospaced font I have on my computer with the same problem. I even tried the font used by my terminal, Fira Mono, to no avail.

I’ve thought of modifying something in the css, but haven’t found anything specific to korean or even non-ASCII characters. I have the feeling that Obsidian is doing something to

copy/paste my table

| 한글 | 한자 | 영어    | example   |
| ---- | ---- | ------- | --------- |
| 문화 | 文化 | culture | 한국 문화 |
|      |      |         |           |
|      |      |         |           |

if you want to try this or check if your solution works you can copy my table to check if you’ve solved it.

Note that this only happens on the editor view, of course the rendered version shows a proper table. The auto formatting also seems to be doing the correct job, and if I open the file on another editor like vim it shows up correctly, but still I’d like to fix it within obsidian.

Also, if it’s relevant, I’m running Obsidian on Linux (Pop OS).

I believe the cause is Obsidian’s default monospace font not supporting CJK characters (not all fonts support these). Install fonts like D2Coding or 나눔고딕코딩, and change the monospace font in Settings > Appearance > Font or 설정 > 테마 > 글꼴.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.