Mixed RTL and LTR

Hi and happy holi days to everyone.currently we have to use plugins to type in rtl but to be honest and with all due respect to developers of the plugins and their hard work , plugins are far from even a usable state.cursor problems and having to manually change the direction each time you open and type in a document or not being able to type in two languages with different directions even after you manually changed the direction are just some of the smallest problems of the plugins.and let’s not even mention that some of the plugins cause text to go fully ape mode sometimes and become vertical making you feel like you are an old monk in a temple on top of a mountian writing an old japanese manuscript.from what I understood plugins can’t fix these issues due to problems with software’s engine.wish someday developers fix this problem.

  1. Cursor problem
  2. Mixed direction in one document (Manually changing direction)
  3. Ape mode

The second problem is fixed by the merge request I mentioned earlier. I think cursor problem (first problem) is fixable to, But I’m not sure about the ape mode :). Pressing Ctrl+a and selecting all the text will fix it, Although its still so much annoying.

1 Like

Gems of the Year 2022 Nomination :white_check_mark: :white_check_mark: :white_check_mark: :pray:t3:

2 Likes

I’m really happy to update here that @zoli and I worked on fixing all the known issues, and the just-released Obsidian RTL 1.0.0 supports mixed RTL-LTR very smoothly (including no cursor movement problems I’m aware of), and some nice new perks :sunglasses:
I think we can say we finally have robust mixed RTL & LTR!

4 Likes


This is great… Is it possible to solve the problem of letters sticking to the checkbox in reading mode?

It should be possible but it doesn’t happen for me, what theme are you using?
Also, are you using any custom CSS or an additional RTL-related plugin?

1 Like

You were absolutely right… the problem must be with a plugin… but I can’t find it… Thank you for your great work :pray:t3: :pray:t3: :pray:t3:

saw the update this morning and I was over the moon ! the cursor goes back and forth with no problems , thank you guys for your awesome work
much love <3

1 Like

happened to me once
I disabled all plugins except for rtl and turn them one by one

1 Like

I forgot to say …the problem was with the Tasks plugin… everything is fixed. :pray:t3:

2 Likes