Missing sidebar settings on mobile / Wrong workspace loaded

What I’m trying to do

View sidebar contents on mobile.

On mobile the both sidebars had content like plugins, folders and sync status. For the last week or so it’s been empty. Photos below.

Currently posting this from mobile, please forgive the brevity.

Things I have tried

Reloading workspace.

Try the debugging steps: About the Bug reports category - #11 by system

I have exactly the same problem as of the last four days.

I think I have tried everything in the debugging post aside from the sandbox vault which I’ll have a look at tomorrow (it’s late here).

I can bring back the sidebar content temporarily by going into the Core Plugins menu and toggling Files and Search off and back on again. When I close and reopen the app, however, they’re gone again. At least it makes the mobile app semi-usable again!

1 Like

There’s no sandbox vault on mobile, so don’t bother with that. :smiling_face:

Are you using Android or iOS? …and is your Obsidian the latest, v1.4.3 (95)?

Use the command palette, show file explorer etc

I am on the latest release of iOS.

I’ve just gone back through and enabled/disabled every community plugin (thanks for the link to the debug thread which recommended Divide and Conquer).

Result: the Homepage plugin is the culprit.

However, I missed this the first time I tested it, because the sidebar settings only disappear if the Homepage plugin is set to open a workspace (not a file, which is its default state) on startup.

@dddave, do you by any chance use the Homepage plugin, and if so, do you have it set to display a workspace on startup?

Either way, I’m going to go open a Github issue! Cheers.

I do, and sorry I hadn’t done the checks yet. I’ve been crazy busy.

The homepage plugin makes sense though. It feels like it started when that large update happened. I do use it and it is set to a workspace. I just tested by setting it it to a page and restarted, and sidebars are back. I suppose an issue should be reported to the dev.

An issue has been submitted already: Setting a workspace as a homepage causes sidebar contents on mobile to disappear · Issue #48 · mirnovov/obsidian-homepage · GitHub

Thanks for narrowing it down.

Update - the developer of the Homepage plugin (mirnovov) has responded and confirmed that the bug is replicable, but has picked up a detail that the rest of us did not.

Even with all community plugins disabled, manually opening a workspace on mobile can cause the sidebar settings to disappear.

Mirnovov notes that workspaces created in mobile mode blank out the sidebar when activated in desktop mode, and workspaces created in desktop mode blank out the sidebar when activated in mobile mode.

I can confirm that I can replicate this, including in Restricted Mode.

So this does appear to be an Obsidian issue, not a plugin issue. I’m not sure of the etiquette here - should one of us create a separate bug report?


thanks I can reproduce

1 Like

the workspaces core plugin should be made aware of device-specific workspaces (mobile and desktop/tablet workspaces are incompatible)

1 Like

I’m still having the issue where my sidebar contents (calendar, File browser, etc) disappear after changing workspaces. Closing and reopening brings them back. This was reported and fixed several releases ago, but somewhere along the way it came back

1 Like

Can you post a screen recording with default theme and no thirdparty plugins?

Same problem here on iPadOS 14.7.1 and latest Obsidian Mobile-App. I don‘t use any themes, css-snippets or external plugins.


Similar here. I can see the folder list and can pull open the backlinks pane, but the calendar doesn’t show up. I can see “Calendar: Open Weekly Note” and “Calendar: Reveal active note” in the command pallet, but that’s it.

I’m getting this behavior on an Android phone and tablet, latest Obsidian app. No custom css or themes, no third party plugins (or any other community plugins), just plain vanilla.

I am also getting this behavior. 1.0.5 version on iOS 15.3.

Me too. I can only use default sidebars on mobile, anything else shows up blank.

I’m still having this problem. Have to close and re-open the Obsidian app for the sidebar to reappear. I use an Android tablet.

This was fixed in v1.5.8