Mermaid Tools doesn't allow editing elements

Hello, I’m having a problem with the plugin Mermaid Tools (Obsidian version: 1.4.13, Mermaid Tools 1.1.0).

I want to add/edit elements in the Mermaid Tools sidebar to create something useful to me, and here comes the problem.

I can add and edit elements in Mermaid Tools Settings, but it can’t save my changes. It just ignores them altogether:

  • when I edit existing templates it just ignores my inputs;
  • when I create something it just defaults to a top-down flowchart that renders “Start ⟶ Stop”

I don’t understand why it doesn’t work as it should be quite straightforward. I’ve tried in my heavily customised vault, in my basically non-customised vault (I just changed the theme) and I tried on a sandbox vault. It doesn’t work in any of them.

As mentioned at the beginning Obsidian is already up-to-date, and I’ve done a clean reinstall a few days ago, (installer 1.4.13 too).

What can I do?

I gave up on using that plugin for just those reasons. I tend to use the online mermaid editor now and copy the content into the code block. The syntax is simple enough that i didn’t need the tools. Plus the online version allows you to do a lot more customisation and experimentation.


Thank you very much for the super-quick reply!
At this point, out of curiosity: have you tried using templates in which there are presets of mermaid graphs? I just thought about it and it could work I guess

Don’t see any reason it would not work. Templates can have anything in them including code blocks.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.