Mermaid Integration: Gantt diagrams - compact display mode does not work

Gantt diagrams in Mermaid have a display mode that puts all activities on a single row called compact display mode. This is a good workaround until Mermaid timelines are implemented/supported. Unfortunately, compact mode does not work.

Steps to reproduce

  • Create a gantt diagram using Mermaid
  • Set the displayMode to compact
displayMode: compact

    title A Gantt Diagram
    dateFormat  YYYY-MM-DD
    section Section
    A task           :a1, 2014-01-01, 30d
    Another task     :after a1  , 20d

Expected result

  • Compact display mode should work as per the documentation

Actual result

  • DisplayMode has no effect whatsoever
  • Diagram is displayed correctly, no obvious error, compact mode line is simply ignored


Obsidian version: v1.1.16
Installer version: v1.1.9
Operating system: Windows 10 Home 10.0.19044
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 6
Restricted mode: off
Plugins installed: 12
Plugins enabled: 8
1: Style Settings v1.0.3
2: Folder Note v0.7.3
3: Advanced Tables v0.18.1
4: Hider v1.2.4
5: Contextual Typography v2.2.4
6: Quiet Outline v0.3.15
7: Editing Toolbar v2.3.1
8: Mermaid Tools v0.2.0

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

As should work:

As is displayed in Obsidian:

We don’t support this. It may also be a new feature of mermaid.

Would you consider supporting this? It’d be pretty useful and the base implementation for the Gantt is already there.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.