Mermaid Chart does not render in live preview

Steps to reproduce

I just tried to use a pie chart. Nothing special.

```mermaid
pie showData
title Allocation
"ASML" : 1184
"Danaher" : 896
"Apple" : 805
"Zebra" : 687
"Texas Instruments" : 546
"NEL ASA": 280

Expected result

The chart should render fine.

Actual result

It just renders a empty box. But it works fine when i switch live preview off.

Environment

  • Operating system: Win 11 64GB
  • Debug info:
    SYSTEM INFO:
    Obsidian version: v0.15.9
    Installer version: v0.15.9
    Operating system: Windows 10 Pro 10.0.22000
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Restricted mode: off
    Plugins installed: 5
    Plugins enabled: 5
    1: Templater v1.12.0
    2: Readwise Official v2.0.1
    3: Annotator v0.2.5
    4: Advanced Tables v0.17.3
    5: Admonition v9.0.3

RECOMMENDATIONS:
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.


Works for me. Post a screen recording of this happening in the sandbox vault and attach a copy of the file.

Thanks for the quick answer!
I’ve attached a screen recording and the file I’ve created.
Again this only happens with live preview enabled.

Mermaid Bug - Obsidian Sandbox - Obsidian v0.15.9 2022-08-16 19-03-57.zip (388.8 KB)
Mermaid Bug.md (290 Bytes)

It looks like pie shifts to the right in edit mode:

More slices I add, more it shifts to the right until dissapears from its render-view

Yeah you are right!
I just switched my Theme and now i can see that the Chart is just shifted.
Which is still a Bug.
@WhiteNoise