MD files won't open, vault changed

Apologies if this has been addressed but I couldn’t find anything in the forum. A few days ago, Obsidian search stopped finding my files. I went to my Mac/Documents/ folder and discovered two things: 1) I now have two vaults. My original notes are in a folder called Obsidian Vault 2, while Obsidian seems to be working with the empty folder Obsidian Vault. 2) When I double click the md files in Obsidian Vault 2, Obsidan opens but my files do not. (They will open in another md editor, however.)

I have no idea what’s going on. I don’t remember making an Obsidian Vault 2. Could there be an issue with iCloud?

What I’m trying to do

I’m trying to restore Obsidian to its prior functionality.

Things I have tried

Rebooting, restarting Obsidian.

Close the empty vault. Go to File/Open Vault and open the right one.

Thank you very much! That worked. Can you explain to me how that happened and how I can keep it from happening again?

A few things to check:

  • System Settings > Apple ID > iCloud > Optimize Mac StorageOFF

  • System Settings > Apple ID > iCloud > iCloud Drive > Desktop and Documents folders sync → OFF

There’s less of an issue (that I’ve seen) with the second setting, but if the first setting is ON, iCloud Drive can and will off-load files to the cloud whenever it feels like it, and Obsidian may not be able to find them.

We don’t know if that’s what happened here, but it’s possible.

2 Likes