Maximized window is smaller/larger than it should be. (white or black border)

When I make Obsidian full screen, there’s a white band that overlaps the taskbar the screen above.

I used the new installer so it’s probably to do with the new Electron version.
I’m on Windows 10, v0.13.30.

I can’t reproduce this.

I just downgraded to the installer for v0.13.23 and it works, so I don’t know what it is then.

is this still happening in 0.13.33?

Yes, still here. I also tried reinstalling and deleting Obsidian’s traces from AppData/ Roaming and Local, and rearranging my screens in different directions in Windows’ Display settings.

I also noticed a further restriction on when this happens: the bleeding over only happens on the main display, so when Obsidian is on the secondary screen, which is below (or also next to) the primary screen to which it overflows.
This bug used to happen for me with some older versions of Chrome too. No generic solutions that I skimmed through worked so far.

Is it possible that this goes away if you change the DPI/scaling of your screens?

I just tried, it doesn’t go away. (And I wouldn’t want to sacrifice the DPI setting for my laptop screen for this anyway.)

This is a confirmed upstream issue introduced in electron 17.

This will be fixed in 0.14.5. You will need to download and reinstall obsidian from the website.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.