MATH LATEX: Wrong pipe (vert) rendering in tables in live preview

Steps to reproduce

  • create a table
  • insert $|$ or $$|$$ into a cell

Expected result

When using $|$ outside of the table, the latex renders correctly by showing a vertical line “|”. This should also render the same way when inserted into a table.

Actual result

When using $|$ inside a table the result is a double vertical line “||”.


Obsidian version: v1.5.3
Installer version: v1.4.16
Operating system: Darwin Kernel Version 23.2.0: Wed Nov 15 21:59:33 PST 2023; root:xnu-10002.61.3~2/RELEASE_ARM64_T8112 23.2.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Base theme: adapt to system
Community theme: none
Snippets enabled: 2
Restricted mode: on

Additional information

1 Like

This is a limitation of tables right now. To make obsidian work in tables | is actually turned in to \| which renders as ||.

1 Like