Math equations cannot be displayed

Steps to reproduce

Type inline and display math and hit the preview button.

Expected result

The math equations are displayed.

Actual result

No math equations showed up.


  • Operating system: Windows 10
  • Obsidian version: 0.6.7
  • Using custom CSS: Yes

Additional information

The console in the developer mode shows as followed.

sre/sre_browser.js:1 Failed to load resource: net::ERR_FILE_NOT_FOUND
mathjax.js:1 Error: Can't load "app://"
    at new l (mathjax.js:1)
    at d.failed (mathjax.js:1)
    at HTMLScriptElement.t.onerror (mathjax.js:1)
app.js:1 FileSystem is case insensitive
mathjax.js:1 Uncaught Error: MathJax retry
    at Object.e.retryAfter (mathjax.js:1)
    at e.checkLoading (mathjax.js:1)
    at Object.renderMath (mathjax.js:1)
    at v.renderConvert (mathjax.js:1)
    at e.n.convert (mathjax.js:1)
    at r.N.convert (mathjax.js:1)
    at Object.S.MathJax.<computed> [as tex2chtml] (mathjax.js:1)
    at (app.js:1)
    at n (app.js:1)
    at gi.render (app.js:1)
DevTools failed to parse SourceMap: app://

It seems that MathJax is not loaded.

That is very odd. Can you try to reload the app with ctrl-r ?

Yes. I tried it many times. It is indeed very wired because it worked very well for a while and suddenly cannot display any math equations.

I even reinstalled Obsidian. Still not working.
Perhaps, I need to completely wipe out any files related Obsidian and then reinstall it?

Does this happen on all pages with math?

Does this happen on a specific page with specific math?
If so, can you share the page with us?

Did you tamper with obsidian in any way? For example using external plugins?

Yes, it happened to all pages and all vaults.
I did not use any external plugins, just a customized CSS.

But I can remember it happened when I was modifying the following page. I added the last equation and then the math display function crashed when I previewed.
The last equation is very long and contains “[”, it probably leads to the problem. But the problem still exists after deleting it.

# Principal component analysis

## Purpose 

To reduce the dimension of a matrix $\mathbf{X}$.

##  Method

### Based on the covariance matrix
* Let  $\mathbf{X}=U\Delta V^{\top}$ denote the [[singular value decomposition]].
* $Delta=\mathrm{diag}[\delta_1,\ldots,\delta_2]$ the singular values.
* $V\Lambda V^{\top}$ give a spectral decomposition of $\mathbf{X}^{\top}\mathbf{X}$ where 
$$ \( \Lambda_{p \times p}=var{diag}\left[\lambda_{1}, \ldots, \lambda_{p}\right]=\mathrm{diag}\left[\delta_{1}^{2}, \ldots, \delta_{p}^{2}\right]=\Delta^{2} \) $$

I don;t know if that is the problem anyway. I suggest you

  1. close obsidian
  2. back up your vault.
  3. delete this folder C:\Users<yourusername>\AppData\Roaming\Obsidian
  4. start obsidian

see what happens

I think this folder C:\Users\<yourusername>\AppData\Roaming\Obsidian should be removed. After removing it and opening Obsidian again, the math display function works!

Thanks so much for your help!

Ops I am sorry, I meant C:\Users<yourusername>\AppData\Roaming\Obsidian.
You are correct!

Please do let me know if this happens again and how it happens!