Markdown links rendering strangely when [ ] is in the linking text

Hello everyone,

I am using the iOS app with the Wikilinks setting turned off. I’m new to Obsidian, but have been using markdown for my notes for a while and don’t wish to convert all my links to the wikilinks style.

What I’m trying to do

I like to use links to other markdown files in the format


With Wikilinks turned off, I would expect this to display


in reading mode. At least, that’s how it is rendered using pandoc, python-markdown, or on online git repos like Instead it shows on the iOS app as


So I have lost the square parentheses [] around the “link” text, and it still shows the (/ part which is ugly (especially for long file names).

Things I have tried

  • Inserting spaces like this [ [link] ](/ This simply displays the whole thing in plain text in reader mode and the link no longer works.

  • Turning wikilinks back on. This doesn’t seem to change anything. I still see “link(/” in the live preview mode.

I was hoping there was just a setting I had missed, but if this is the expected behavior of Obsidian and I haven’t missed anything, then I would like to make a feature request. Using the wikilinks features as intended by removing the explicit (/ breaks my notes when opened in other environments, so I don’t want to go down that route at all.

If anyone could give me some pointers I’d really appreciate it! Thanks.

I think this is a bug. Could you file a bug report? You can copy-paste parts of this post as needed but please follow the bug report template.

I confirmed the behavior on iPadOS and Mac. A few more things I noticed, which you’re welcome to include in the report, or I can copy them into a comment on it:

Looks the same in Reading View.

Removing the leading slash on the path doesn’t help.

Adding the brackets to the text of a working link produces the same behavior.

The help documentation on supported internal links lists only two formats.

Even with the “use [[Wikilinks]]” setting off, you can ignore the Markdown link auto-complete and still manually type [[mynote]]; the link will work fine.

Because Obsidian recognizes both [[wikilinks]] and [markdown]( mixed together in notes, you are going to have a problem trying to use [[link]](/ with the extra brackets. Seems the parser sees it as an wikilink and ignores everything after the last ]

I think what they’re trying to do should be possible despite wikilink support, altho it’s not shocking that there’s a problem.

I tried escaping the inner, then outer brackets to see what happened, and things just got worse.

1 Like

Oh yeah, I tried that too but forget when I was writing things down! :sweat_smile:

1 Like

Thank you for the discussion, I have filed a bug report just now! Markdown links break with [ ] in the linking text

1 Like

Thank you for the discussion. That explanation makes a lot of sense to me. Hopefully it can be fixed.

Semi-related: I also just noticed, that if you try to make a link from an image, e.g.


then there is no issue with escaping the last ] anymore – that is, the image displays fine without any extra text being displayed. However the link doesn’t work when clicking the image! But that’s probably a separate discussion on whether that’s a good idea or not! :joy:

The following syntax works to add a link to an image:

[![cat]( 'a little kitty')](


1 Like

Oh you’re right! I was mistaken, the example I gave works fine – I had missed the little external link icon and expected that clicking on the picture would open the URL, but it instead just makes the picture pop out in the foreground of the phone screen.

1 Like

Like this?



That seems fine in LivePreview mode for external links (if you click right on the outgoing link icon), but I was trying with internal links in Live Preview.

1 Like

Ahhhhhhh, the perils of choice. :melting_face:

1 Like

Both work in Reading mode.



Wonder if that’s good enough? :thinking:

1 Like

I see exactly the same. These also work in reading mode, although they render with a different visual.