Markdown links are not clickable in the edit mode

Steps to reproduce

  1. Create a markdown link e.g.: [My Note](my-note)
  2. Try to click the link using CMD+Click in the editor

Expected result

The link should open, same way as the regular [[My Note]] links open in the editor.

Actual result

The markdown link does not open in the editor

1 Like

Cmd+Double-clicking works for me.

1 Like

How does your link look like?

[Google](google.com).

Or did you mean links to notes formatted as markdown links? If so, why not use [[note]] syntax?

I can repro. But I did notice that your computer will try to open the file with the default program when you Cmd+click on it, does that happen for you too?

The cause of this is that we don’t parse Markdown links inline yet, in the sense that we don’t check if it starts with http or not, and just let your system takes over.

For example, if you have [Google](google.com) and you actually have a note called “google.com”, what do you expect Obsidian to do? There are even domains that end with .md now (like obsidian.md :wink:), so it’s increasing hard to know whether you’re talking about a local file or a website. That’s why I would recommend using [[links]] too if possible.

2 Likes

Additionally. For me, markdown links don’t work with the cursor either. Putting this here rather than another bug report because it’s likely related.

Was about to create a bug report when I found this thread.

In the edit mode, links behave differently depending on how you format them:

[[link]] -> gets an underline on mouseover + works with CMD+click.

[link](link.md) -> does not get an underline on mouseover + does not work with CMD+click.

Problem is: at least for me (Mac) all links created with the autocomplete helper (the list of already existing pages) uses the second notation, which is not working as expected.

Sure, I could just use [[link]] by ignoring the helper and manually typing each character as @ryanjamurphy mentioned, but that totally deprives me of the benefits of the helper, which is obviously helpful when linking to pages with long names.

It’s easy to use [[page]] and ignore the helper, not so much when linking to [[a-really-long-page-name-for-no-special-reason]].

PS: strangely enough, the autocomplete helper does not work in this faulty way when I try to edit the default Obsidian help docs. It always uses [[link]] instead of [link](link.md).

Why is that? It’s driving me crazy :frowning:

Difference in the settings?
Markdown links turned on in your vault but not the help vault?

2 Likes

OMG thank you so much @Dor!!! Have no idea why was that setting on, but it solved the problem!

1 Like

So, this issue is solved, isn’t it?

No

[link](link.md) -> does not get an underline on mouseover + does not work with CMD+click.

as @mark1nhu mentioned.

1 Like