Markdown is not well formatted in source mode on Obsidian Mobile (Android)

We strongly recommend you to search the forum with possible keywords before submitting a new bug report. Please also try your repro steps with third-party plugins and custom CSS disabled and see if it’s still reproducible. If it’s an issue with third-party plugins or themes, try contacting the author for help. Once you’ve done the above, delete this line.

Steps to reproduce

I can’t reproduce the bug. It happens from time to time in source mode only in obsidian mobile on my Samsung Galaxy Tab S7+ and smartphone Oneplus 6

Expected result

Well formatted document in source mode

Actual result

Sghown in the attached picture


  • Operating system:
  • Debug info:
    Operating system: android 12 (samsung SM-T970)
    Obsidian version: 1.3.1 (65)
    API version: v0.15.9
    Login status: logged in
    Catalyst license: supporter
    Live preview: off
    Legacy editor: off
    Base theme: light
    Community theme: Blue Topaz
    Snippets enabled: 6
    Restricted mode: off
    Plugins installed: 12
    Plugins enabled: 12
    1: Calendar v1.5.10
    2: Advanced Tables v0.17.3
    3: Editor Syntax Highlight v0.1.3
    4: Dataview v0.5.41
    5: Obsidian TODO | Text-based GTD v0.2.7
    6: LanguageTool Integration v0.3.0
    7: Excalidraw v1.7.13
    8: Kanban v1.3.15
    9: Extract url content v0.12.1
    10: PDF Highlights v0.0.4
    11: obsidian markmind v1.5.4
    12: Style Settings v0.4.10

Custom theme: for cosmetic issues, please first try updating your theme to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

What is it supposed to look like?

You didn’t take the time to explain the problem. And your screenshot is very low resolution.

Post a screen recording of this happening in the sandbox vault (on not themes/ no plugins) and attach a copy of the document where this happens.

“### Toyota Auris” is not formatted as Markdown. This happens in longer documents very often. The first part is well formatted, then a part is only black (not formatted as markdown), after some of this not formatted lines, the formatting works well. It only happens in ‘source mode’. After reloading obsidian the error is gone…

When it happens I will add some further screenshots

Where our how do I get the sandbox vault?

If you are in source mode, what you are seeing is correct.

Not understand what you are saying and which one you mean. This is work in mobile reading/editing/source code mode.

Take a look on the screenshot after only reloading obsidian. In the first screenshot the heading ‘### Toyota Auris’ is shown as normal text in black and white. After reload it is correct shown as heading (h3)

I will post some further screenshots when it happens. Then all markdowns like headings, lists, check boxes not working.

Remember, default theme and no third party plugins.

(Also, sorry your original screenshot was just fine. I was viewing it on mobile, and it was all pixelated. On a computer, it shows up fine.)

Obsidian loads documents in parts as they are scrolled into view. Sometimes when you scroll (most often in longer documents) you will see unstyled text briefly before it is rendered. It seems yours is getting stuck in that state sometimes.

Do you need to reload Obsidian to fix it or can you just reload the note (by going to a different note and coming back)?

I have to reload obsidian most of the time. Can I switch this behavior off? It only happens in the mobile version on Android.

Typically the document is well formatted and when I insert or change something, then parts are wrong formatted

Use the default theme, use restricted mode (no third party plugins). Post a screen recording of this happening and attach a copy of file that is causing this.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.