Markdown footnotes don't work in Obsidian Publish with iPhone/iPads and macOS in Safari

See example on first line of 🧘🏻 About

Footnote links and sends to an Obsidian URL β€” β€” instead of bottom of the page.

All Apple devices have it broken, including iPhones, iPads, and Macs w/ Safari/Webkit.

Works fine on Chrome/Android.

we are unable to reproduce this. Post a screen recording.

Also your publish.js is throuwing errors. Is it possible that that’s the problem?

Yeah I tried to remove publish.js and disable any possible content blockers on Safari. Still same error. Attaching video also shared with @Licat on Discord, @WhiteNoise.

Video: Filebin

You didn’t mention opening in a new tab.
That is not supported neither in chrome nor in safari.

what device are you on?

It it possible that you have some browser extentions that are interfearing with this?

Found it. It’s StopTheMadness.

Not sure by which mechanism, as other in-page links to sections work fine.

Also, just be clear: I love Obsidian. Reporting tiny, weird bugs feels a bit ungrateful and I try to check anything I can before doing so. Thank you for your help.

Cross posting from Discord:

That extension seems to prevent the page from running JavaScript on link clicks, which is used by some sites to track clicks. Unfortunately, Obsidian publish uses the click event handler to actually perform the scroll and highlight.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.