Malfunctioned Ctrl, Shift and Alt in Obsidian

What I’m trying to do

I set Hot key for Search engine in Obsidian by clicking “Shift” button twice. And whenever I mistakenly enter this hot key, my Shift, Ctrl and Alt buttons do not work in Obsidian (they work properly in other apps, I unsure about the reason).

Things I have tried

  • Uninstall both the Search and Hotkey Plugins.
  • Sometimes, when I tried to switch the focus back to my current note using “Esc” button, I could regain the function of the Ctrl, Shift and Alt buttons. But most of the case, it does not work

Currently, I tried to restart my Vault, it works but is takes a great deal of time to do that. So can you guys please help me!!!

Which “Search and Hotkey” plugins were you using?

Of course there may be a plugin that can do it, but I haven’t come across one that allows double modifiers (Shift + Shift) in Obsidian.

Is there some software outside of Obsidian where you’ve set this?

I’d try in the Sandbox vault and the other troubleshooting steps to see if it’s something about that vault, Obsidian itself, or something outside of Obsidian. You could also paste your “debug info” (cmd/ctrl + pShow debug info ) here so folks have a better idea of your setup.

Thank you for your advice. At least I have some things to bear in mind now and know what to do next. Below is “my debug info” for your further helps:

	Obsidian version: v1.4.16
	Installer version: v1.4.16
	Operating system: Windows 10 Pro 10.0.22621
	Login status: not logged in
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: Obsidian Nord v0.2.0
	Snippets enabled: 3
	Restricted mode: off
	Plugins installed: 24
	Plugins enabled: 23
		1: List Callouts v1.2.0
		2: Custom Frames v2.4.6
		3: Core Search Assistant v0.9.2
		4: Obsidian Columns v1.5.2
		5: Highlightr v1.2.2
		6: Paste URL into selection v1.7.0
		7: Doubleshift v2.2.1
		8: Imgur Plugin v2.4.0
		9: Linter v1.20.1
		10: Footnote Shortcut v0.1.3
		11: Admonition v10.1.1
		12: Banners v1.3.3
		13: Multi-Column Markdown v0.8.3
		14: Excalidraw v2.0.1
		15: Iconize v2.8.0
		16: Calendar v1.5.10
		17: Periodic Notes v0.0.17
		18: Recent Files v1.3.8
		19: Omnisearch v1.19.0
		20: Templater v1.18.0
		21: Dataview v0.5.64
		22: Excel to Markdown Table v0.4.0
		23: Buttons v0.4.19

	Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
	Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

I followed troubleshooting guidance steps by steps as per your advice. Let me try to figure it out that bugs belong to which plugins/ themes. But it must take time cause I have 24 plugins :smiling_face_with_tear::smiling_face_with_tear::smiling_face_with_tear:.

You could use the Divide & conquer plugin to make that somewhat faster, as it helps you narrow down your search very fast by disabling/enabling half the plugins for you in each step.

1 Like

Sorry for my late response. It’s been a while since my last check of noti in Obsidian forum. Your recommendation is eye-opening for me. Many thanks for your reply.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.