Make mouse wheel scroll work for graph view zoom even with mouse setting of scroll by one full screen per step


(Some function fails for some Windows settings, so I reported it as a bug, but it was moved to Bug graveyard and I was asked to resubmit it as a feature request. So here it is rephrased as a feature request.)

Use case or problem

When opening graph view, zooming in and out with the mouse wheel fails. As I just verified, this is because my mouse wheel is set to scroll one full screen for every step, instead of several lines (I don’t have Windows in English so I can’t quote the exact UI strings).

Proposed solution

The Windows app might check for this setting and adapt the zoom behavior accordingly.

Current workaround (optional)

Change the mouse scroll Windows setting. Note that I have been using this mouse setting forever, and use it every day since I do all my web reading with it. Therefore I am not actually using this workaround, as this mouse setting is even more important to me than viewing my notes in graph view. Here’s a link to someone who said they have the same issue (not the OP of the topic):


1 Like

Same issue with the new canvas feature… Note that zooming with mouse wheel works fine elsewhere in Windows, e.g. in Google Maps or in Chrome. Hence a bug rather than a missing “feature” in my view.