Made a stupid mistake in Style Settings, now app unusable

What I’m trying to do

I am relatively new to Obsidian and tried customising the Prism Theme through the Style Settings plugin. While selecting a colour scheme, i accidentally clicked on “custom”, and ever since my Obsidian has basically been a blank screen. There is an empty folder icon in the top left corner, a small grey arrow i can click on to sort some non-existent files by different categories, and swiping up gets me a “save current file” button. I can type anywhere on the screen, but no text shows up. I’m using the mobile version & I have darkmode enabled, if that information is relevant.

Things I have tried

None of the few interactions I can have with things on my screen seem to lead to anything. I also have no way to access settings, so I can’t undo my mistake. The obsidian files saved on my phone won’t open in the app. I’m 100% lost here and would really appreciate any help!

If you don’t mind losing any changes you may have made to that plugin’s settings, try opening Obsidian and then pressing Ctrl + , to open Obsidian’s Settings and then uninstalling the plugin.

If that’s also blank, that’s not much use then. You’ll need to do it via File Explorer instead (assuming you’re using Windows):

  1. Close Obsidian.
  2. Go to the location where your vault is saved on disk, and in it find and open the .obsidian folder.
  3. Inside of that, find and open the plugins folder.
  4. Finally, inside of the plugins folder, find the style-settings folder (or obsidian-style-settings – I’m unsure of its name) and cut and paste it onto your desktop.

You’ve uninstalled the plugin. Open Obsidian and things should be back to normal, in theory! Re-download Style Settings if you want to have another go at customising the theme. You should be able to find the file you’re customising on disk too and edit it in Notepad or something to undo any change (instead of uninstalling and reinstalling the plugin), but I don’t have any experience with Style Settings so I couldn’t tell you how exactly.

You can delete the plugin folder you copied to your desktop once you have determined you didn’t lose anything you had hoped to have kept.


Thanks so much for your detailed reply!
I’d probably have to take the file explorer route, but sadly this happened in the Android mobile app (I don’t have sync) and all that i can acces in My Files are the vaults, not the app itself. Do ou have any idea how i could still delete the plugin?
Or would deleting and redownloading the app work if I keep a backup of my vaults?

According to Obsidian Help, the vaults on Android are located in Documents/Obsidian. I’m not sure if Obsidian stores the vault’s settings the same way as it does on PC using a .obsidian within the vault folder, but it looks like it might. Check for the Documents/Obsidian/<your_vault_name>/.obsidian/plugins folder and delete the mentioned Style Settings folder from within it.

Since vaults probably store their settings within their vault folders on Android, backing up your vault will only back up the problem too. I think you need to just rid of the Style Settings folder. You might want to back up your vault before doing anything, just in case.

Everything PKMian said.

I’ll just add vaults on desktop are the same a mobile (all settings/themes/plugins/CSS snippets are in the .obsidian folder). So, you just need dig into the location using Android’s file browser or an app than can see hidden files and folders.

Moving or renaming the .obsidian/community-plugins.json file is also an option. This will disable all community plugins. Then you can remove and reinstall Style Settings from within Obsidian.

Thank you so much for your input! I copied the vault into a cloud that let me view the entire folder, and luckily it had the .obsidian folder attached to it. Then I recopied it into my storage and made it into a new vault. Lots of back and forth, but I haven’t lost anything but some formatting. Uff. Thank you again for helping me so quickly!!!

1 Like

No problem, glad you got it working again!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.