(MacOS) Obsidian app won't start

Steps to reproduce

  1. Start Obsidian app (via double click or Spotlight)
  2. Observe that Obsidian icon appears, then disappears a second later. The obsidian window never appaers.

Did you follow the troubleshooting guide?


Because it’s impossible to switch to the sandbox vault without actually running the app, the sandbox step is not applicable.

Expected result

I expected the Obsidian window to appear.

Actual result

The Obsidian icon in the dock appeared, then disappeared a second later.


Obsidian version: v1.3.5
Installer version: v1.3.5
Operating system: Darwin Kernel Version 21.6.0: Thu Jun 8 23:57:12 PDT 2023; root:xnu-8020.240.18.701.6~1/RELEASE_X86_64 21.6.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: Obsidian gruvbox v0.1.8
Snippets enabled: 0
Restricted mode: on

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.

Additional information

  1. I use Obsidian on my mac laptop daily.
  2. This morning, Obsidian mysteriously failed to launch as described above. Google Chrome exhibited the same behavior. The OS also notified me that an update was required. I’m not sure if these are all related.
  3. Obsidian on my iOS device continued to work normally (I use iCloud to access the vault).
  4. After many different attempts (re-installing Obsidian, moving the vault’s .obsidian directory), I finally got Obsidian to launch by renaming ~/Library/obsidian out of the way.
  5. The problem is reproducible: I still have the offending obsidian folder. When I rename the bad obsidian folder back to “~/Library/obsidian” the problem re-occurs.

So it works now?

Out of curiosity, have you tried restarting your computer?

Yes, it works now.

Yes–because of the OS update, I rebooted my computer quite a few times. Rebooting did not resolve the problem.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.