MacOS drag Obsidian window issue: not working consistently

Environment: macOS 12.5.1
Obsidian v1.0

Steps to duplicate the issue:

  1. Open Obsidian
  2. Move the Obsidian window around - doesn’t work.
  3. Move another window around (e.g., Chrome browser) - works
  4. Click and drag Obsidian window around - works now.
  5. Release mouse click to stop dragging window of Obsidian. Try to move it again - doesn’t work. … until you click another window first.
1 Like

What is your Settings → Appearance → Window frame style set to?

I can click and drag the window just fine, even when it’s hidden. Make sure to test with updated plugins and themes, and no snippets. Test with the default theme.

Potentially related threads:


Just to add to this. It would be nice if the window maximized when double-clicking the top window frame. (MacOS)

A few answers:

  1. Window frame style was set to Hidden (default)
  2. I was using the Things (Legacy) Theme. When I reset it to the default theme, it worked fine. So your hunch that it is theme, is spot on.
  3. After I did an update on the Things theme, it is still listed as “Legacy”, yet the problem has gone away.
1 Like

Can confirm that this is a theme dependent issue. Had a similar issue with the “California Coast” theme which resolved with default theme; no change with updating theme, however.

I had the same issue in Windows 11. Moving from Things to Default theme fixed the issue.
Thank you everyone for the help!

same issue here on MacOS 12.6. Changing theme to “Default” fixed the issue.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.