macOS default hotkey conflicting with Obsidian editor

Steps to reproduce

  • Open Obsidian in macOS
  • Open a file in the vault
  • Use the Hotkey “Globe Key (Fn) + F” to enter full screen
  • If a file is opened in Obsidian, then there will be an addditional letter f showing up in the file

Expected result

After pressing the Fn(:globe_with_meridians:) + F Hotkey to enter full screen, f will not be typed into the file.

Actual result

After pressing the Fn(:globe_with_meridians:) + F Hotkey to enter full screen, f will be typed as an unwanted letter into the file

Environment

  • Operating system: macOS 12.6.1
  • Debug info:
    SYSTEM INFO:
    Obsidian version: v1.0.3
    Installer version: v1.0.0
    Operating system: Darwin Kernel Version 21.6.0: Thu Sep 29 20:13:56 PDT 2022; root:xnu-8020.240.7~1/RELEASE_ARM64_T6000 21.6.0
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: adapt to system
    Community theme: none
    Snippets enabled: 0
    Restricted mode: off
    Plugins installed: 1
    Plugins enabled: 1
    1: LanguageTool Integration v0.3.1

RECOMMENDATIONS:
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.


Additional information

The gif for reproducing the bug
屏幕录制2022-11-10 18.54.05

1 Like

Toggle Full Screen is Ctrl+Cmd+F not Fn+F

Screenshot 2022-11-10 at 11.45.59

But it is Fn(:globe_with_meridians:) + F on my end

As it happens, I installed Monterey last night, and now see similar:

Screenshot 2022-11-11 at 14.56.12

Strange that this change was invoked by an OS update, but there you go.

Anyway, in my case, both fn+F and Ctrl+Cmd+F cause Obsidian to go full screen, and I see the behaviour you’re reporting with Fn+F.

Yes, thanks for testing it out. command + control + F does work well, but I’m used to usnig Fn + F for full screen :smile:

I can reproduce. MacOS 12.6

1 Like