MacBook Pro M1 won't honor or allow me to create certain hotkeys

What I’m trying to do

Use a hotkey combination to toggle the side bars. Combination is cmd+ctrl+option+left arrow or cmd+ctrl+option+right arrow.

Things I have tried

I can successful use these hotkey combinations on my non-Apple Silicon iMac, but they do not work on the MacBook Pro M1 I just got. I used an online keyboard test and all keys function as they should. Any idea why this is happening?

Just tried in the Sandbox vault.

macOS 13.5.1, M1 pro, Obsidian v1.4.5. Working over here.

CleanShot 2023-09-06 at 04.55.29

Could be something about that vault. You can try in the Sandbox, a new vault, or the other troubleshooting steps.

1 Like

I did go through the troubleshooting steps and I still have the issue. Trying to add the same hotkey combination in the sandbox failed (would not allow me to add it). Same for a new test vault . I’m running macOS 13.5 (22G74) with Obsidian v1.4.5. I’ve looked else where for conflicting hotkeys, but didn’t find any matching the combo. Any idea what my nexts steps should be?

Testing on a MBP Pro M1. Works fine here too.


What language/region is your keyboard layout? And what language/region is your keyboard input source set to?

You could try mapping the hotkey in another app, and see if it’s blocked there too. That would be an excellent clue that you have a conflict somewhere.

You could try making a new user account on your computer, and see if it works there, as a test.

My personal preference for toggling the sidebars: Cmd-] and Cmd-[

That’s very easy to type. And you can hit both at the same time.

1 Like

Good tip. Same behavior in VS Code. It was more about trying to figure out what’s wrong than creating a new hotkey combo. I’ll continue digging and see what I can find. Thanks the tips!

I second this. Being a M1, it won’t take much time to create and login into a test account. Then you’ll know for sure if it’s something installed, left over cruft, etc., in your main account or a system wide issue.

Created a new user as suggested and the hotkey combo works as expected. So the million dollar question is, how to I diagnose this issue with my account? I closed all active apps other than Obsidian and I still experience the issue. I also went through all the keyboard shortcuts in Settings and didn’t find any with the same combo.

What potential apps do you have installed that deal with hotkeys?

Karabiner Elements, BetterTouchTool, Alfred. That kind of thing.

Don’t forget some apps run in the background, or as services. (I’m sure you know that, but just in case.)

I have never tried this, so I don’t endorse it without investigating. But it sounds like there is an app ShortcutDetective that can detect which process is receiving a hotkey: macos - Find which process receives a given keyboard command - Ask Different

That same thread talks about using “opensnoop” in the Terminal, which appears to be included by default in MacOS.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.