Mac terminal does not see obsidian folder

Things I have tried

trying to enter my obsidian icloud folder from terminal
i see folders in my icloud but not obsidian folder
in finder obsidian folder has small obsidian icon included
inside i have two folders for my two vaults
i see those folders and can access them in finder but not in terminal

What I’m trying to do

access obsidian folder from CLI
to use some js libraries on markdown files

Does it work if you right-click the Obsidian folder, and in Services select New Terminal at Folder?

You can also right-click the folder, press Option, and select Copy "Obsidian" as Pathname, then past it in Terminal (and in Obsidian to save for later).

1 Like

When in Terminal and doing ls, it doesn’t show hidden folders, like the .obsidian folder, but it is there. To actually see it, you need to do ls -a. You can also just change into it (without seing it), using cd .obsidian when you’re standing in the vault folder.

When in Finder, you need to hit Shift + Cmd + . when you’re standing in the vault folder, to see and access the .obsidian folder.

(Not sure how to get to the ICloud folder in the first place, but when in the vault folder my suggestion should work)

I think they’re looking for the folder that contains their vaults, but I could be mistaken.

1 Like

Possibly, I kind of read it the other way, I guess we will just have to wait and see if the OP rereads his question, and satisfied or not. :smiley:

if you are using iCloud, you can see your vault(s) are here:

ls -al "$HOME/Library/Mobile Documents/iCloud~md~obsidian/Documents"
1 Like

To help with this, cd to the folder containing your vaults and run (in terminal):

ls -la
pwd

And paste the results here. Should give us a clue whether you’ve got odd permissions and whether you’re in the “right” place.

yes it works!

Thank you guys so much for help!

What worked:
@CawlinTeffid > Right click + cmd > services > new terminal at folder
@egauthier > also the direct link from

What did not:
@OGRobrain > was unable to see my obsidian folder with ls -al

i> Mac-Robert:com~apple~CloudDocs robert.matyszewski$ ls -al

total 56928
drwxr-xr-x 11 robert.matyszewski staff 352 Dec 14 14:14 .
[email protected] 114 robert.matyszewski staff 3648 Dec 22 19:33 …
-rw-r–r–@ 1 robert.matyszewski staff 14340 Dec 31 13:44 .DS_Store
[email protected] 38 robert.matyszewski staff 1216 Dec 31 13:38 .Trash
[email protected] 1 robert.matyszewski staff 35 Nov 25 13:28 Documents → /Users/robert.matyszewski/Documents
[email protected] 4 robert.matyszewski staff 128 Jan 1 16:38 Downloads
-rw-r–r–@ 1 robert.matyszewski staff 29126884 Jul 6 2017 IMG_0009.MOV
[email protected] 5 robert.matyszewski staff 160 Jun 6 2022 Notes
[email protected] 11 robert.matyszewski staff 352 Dec 21 11:18 Zdrowie
[email protected] 3 robert.matyszewski staff 96 Nov 25 10:08 books
[email protected] 5 robert.matyszewski staff 160 Dec 31 13:44 ibooks
iMac-Robert:com~apple~CloudDocs robert.matyszewski$ pwd
/Users/robert.matyszewski/Library/Mobile Documents/com~apple~CloudDocs
iMac-Robert:com~apple~CloudDocs robert.matyszewski$

My final goal is to use markdown-merge on my old daily notes to merge them. I am unable to run the library inside my obsidian icloud folder, but when i copied daily notes subfolder to my desktop it worked. On icloud i get error:

iMac-Robert:04-2022 robert.matyszewski$ merge-markdown -m /Users/robert.matyszewski/Library/Mobile Documents/iCloud~md~obsidian/Documents/Robert/02 journal/*2022/04-2022
\Error: ENOENT: no such file or directory, lstat ‘/Users/robert.matyszewski/Library/Mobile’

1 Like

Are the files downloaded to disk, or are they just placeholders for files in the cloud?

They are in the disc, I am able to copy them to desktop

If you mean copy by dragging them in Finder, that doesn’t mean they were on disk. If you used cp in Terminal, then maybe they were.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.