Mac M1 can't open markdown file

What I’m trying to do

I’m using the Better BibText plugin to create a markdown file from my Zotero annotated notes. When exporting my notes from Zotero to Obsidian, a markdown file is created (I can see it in my folder locally) but it can’t be opened in Obsidian. It’s clear that it is a markdown file.

Things I have tried

I tried looking at “Get Info” for this file and the only difference I see between the markdown files that are openable in Obsidian and the one that is not is that the file type for the valid ones are called “TextEdit Document” while the invalid one is called “Document.” Could this be causing the issue? Are there different types of markdown files?

Do the files have different extensions? I’m assuming so since the Mac says they are different document types.

They’re supposed to have the .md extension.

1 Like

You said you can see it in your folder locally. Which folder? Your vault?

How exactly are you attempting to “open” the file in Obsidian? Are you talking about from inside Finder?

Obsidian doesn’t “open” Markdown files from your filesystem. It looks at Markdown files that are inside your vault. You can drag a Markdown folder into Obsidian, and it will copy it into your default attachments folder.

But otherwise, if you are in Finder, all you have to do is move or copy the file somewhere into your vault folder. Maybe that is what you are already trying, and still can’t see the file? Then the question is like holroy said, what is the file extension?

Better Bibtex doesn’t export markdown on its own. How exactly are you creating the markdown files?

You best bet you be to use one of the plugins that integrate Obsidian and Zotero, like Zotero Integration or Zotlit.

I see the Markdown file in my Obsidian vault and it has the .md extension but for some reason Obsidian doesn’t treat it as a regular Markdown file.

How does it treat it? Maybe show a screenshot. It doesn’t seem clear from your description.

1 Like

A few other things to check:

  • You said the content originally came from Better Bibtex. I’m not familiar with that syntax, but could something malformed from there be “breaking” the file in some way?
  • How large is the file on disk? 10KB? 1MB?
  • Can you open the file in another Markdown editor, e.g. MarkText, Typora?

Yes, please show a screenshot and/or, if the file doesn’t contain personal data, upload it somewhere so that others can have a look.

1 Like

Screenshot 2024-02-10 at 8.39.57 AM

The “minSILOLanguageMo…” file is the one created by Better Bibtex and it has a special “MD” marking next to it whereas original Obsidian files like the one above and below do not

This is what the markdown file looks like which can be opened in the default TextEdit on Mac but not able to open it in Obsidian even though I moved it to the vault

I’m still suspecting your file extension to be strange. More specific I’m thinking that your file ends with .md that’s with an extra space at the end.

So try in Finder to change the file extension into something else, like .txt, and then change it back into .md.


Excellent guess! I can recreate the issue if I rename a file with .md␣ with a space.


1 Like

That solved it, thank you!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.