Mac: Exporting to PDF

Things I have tried

  • The Command Palette (can’t find anything like Export or Print)
  • The Mac menu System (ditto)
  • Turning on plugins (ditto)
  • Cmd-P should normally start a Print dialog from which I can save to PDF, but that doesn’t work either.
  • Select-All / Copy / Paste into Typora so that Typora can export it (nothing is pasting at all; so I think nothing is copying).
  • Open in Default App: This brings up an abbreviated Share menu with Copy as an option, but only the File path/name is copied.

Would it be fair to say that Obsidian wasn’t originally written for the Mac? It doesn’t seem to follow normal Mac conventions.

FYI: I’m on a Mac Air M1 using Big Sur

What I’m trying to do

Export or Print to a PDF, or even some kind of intermediate format.

In the top right of the note, you find three dots:

Click and find “Export to PDF” at the bottom of context menu:

Another way with keyboard: CMD+P, then write “export” and the command “Export to PDF” shows up.

1 Like

“Works for me”. Actually I think export to PDF is provided by the Pandoc Plug-In (community plug-in). I would agree with you that this should be ‘core’ rather than ‘community’.

I have Export to PDF with only Core plugins.

1 Like

Thank you for the response! I think there is something wrong with my installation or configuration. I have nothing close to the same context menu as you:

The Cmd-P | type ‘export’ idea (I believe this is the command palette) doesn’t work either. There is nothing like Export:

Thank you for the response. This might well be the issue. My context menu is woefully smaller than others and my command-palette too. I’ve not turned on community plugs because it is not the default configuration. I will try that sometime today.

Thank you for the response! In my list of Core plug-ins, export or print or anything like that is not available.

I was looking at Community Plugins in the Settings menu and it said I needed to turn off ‘Safe Mode’. When I hit that switch I get this ominous warning:

This seems to be an official position from the Obsidian developers. It makes it sound like I really shouldn’t be doing this. I don’t want to open my computer up to software that can read any of my files (I am a consultant and I have client data on my computer.) This would even go against the policy terms for my Cyber Insurance.

Is there some other way to get this ability?

What’s your obsidian version? This seems the mobile version!
Do you use the default theme?

I’m on a Mac.


I haven’t changed anything about themes. I’m running pretty much the stock installation, though I have tried turning on various things to see if a printing or exporting was hidden somewhere.

However, I do have the mobile version (iPhone), I just don’t use it. Could having two versions be breaking something? I did open my phone just now and the context menu does seem suspiciously similar to the context menu on the Mac.

I’m sorry, but something is wrong!
You’re using mobile version: 1.0.4 is the current mobile version! The last desktop version is v0.12.12 (or v0.12.13 for insiders and so one).
I’m in an old Macbook Pro, not a M1 one. But I think the M1 has the ability to allow you to install iOS apps in your computer.
Do you install the app via App Store or via Obsidian website? If the answer is the former, then definitely you have the wrong version (desktop app not available in App Store).
If you open the settings modal the first topic is “Mobile”?

1 Like

THANK YOU! That must be the answer. I’m almost certain I installed it from the App store, which normally just hands over Mac applications.

I so appreciate this. I will remove what I have and go install from the Obsidian website.

1 Like

BANG! It worked.

This was it. I have an export to PDF and all kinds of other things that I didn’t have before.

Thank you again.


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.