Lost content of the file [Linux, Snap]

What I’m trying to do

I have a vault. I have a file in it. I opened that file and the content in that file was a snapshot of the content that was there before, but it wasn’t the last state. In other words, I remember writing something in that file and that thing wasn’t there. The state of the file was like from the past.

I have no idea why. I have no idea why the content of the file wasn’t like I left it, but it was something from the past.

Ideally, I’d like to recover the new content of the file (probably impossible, since the content of the file is already different). So, I want the new state of the file, not the old one.

But I’d also like to understand what happened (for example, so it won’t happen in the future). Possibly, it’s not just the file, but also entire vault. I mostly modified that one file in it, so if the entire vault reversed to the previous state, I wouldn’t notice.

I think one time when I worked with another vault, Obsidian displayed a message to me. It went something like “Obisidian recovered a vault”. But I have a very vague memory of that message, so I might be totally mistaken. When I saw that message I was like “what vault? what are you talking about, I didn’t need to recover any vault”? Possibly, Obsidian recovered some old state of the vault then and replaced the new vault with the old content, as a result of some bug, thinking that it’s helping me, but in fact losing my data. But I have very low confidence that that is what has happened.

Things I have tried

I tried to go to “File recovery” and see snapshots for the file. But there wasn’t any satisfying snapshot. The snapshots are held only for 7 days, and my last edit of that file was before 7 days.

Specify where you vault is located, what OS, which folder.
What sync service are you using?

  1. If you aren’t keeping periodic backups, I recommend you do. (Sync tools are not sufficient backups.)
  2. I recommend increasing the duration of File Recovery. I set mine to 600 days, and every 3 minutes.
  3. What gino_m asked. But also if you could share your “Show Debug Info” maybe there are some plugins that are causing issues.

The most likely thing that happened in cases like this is that you are using some sync/cloud service. Or bad: 2 or more sync services which are conflicting with each other.

Or maybe someone knows what that “Obsidian recovered a vault” message was. Did you ever lose power in a thunderstorm, or experience a computer crash while working in Obsidian?

Do you use Obsidian Sync?

Do you use a sync/cloud tool like iCloud, Dropbox, OneDrive, Google Drive, SyncThing, etc. etc.? And if you aren’t sure, like gino_m asked, what folder do you store your vault in? Because some default folders in MacOS or Windows are set to automatically sync with iCloud or OneDrive.

My vault is located in a normal folder, somewhere in /home directory.

OS: Ubuntu.

I don’t use any Sync service. Even “Sync” core plugin is turned off.

Thanks for the recommendations.

“What gino_m asked. But also if you could share your “Show Debug Info” maybe there are some plugins that are causing issues.”

Where can I find the debug info?

I don’t use any Sync service or Obsidian Sync.

What did you use to install Obsidian? Snap or Flatpak?

Ubuntu Software / Snapstore.

Obsidian doesn’t vouch for those (as far as I know).
Can you install debian package? They work perfectly for me.

Run the command palette in Obsidian. (Ctrl-P)

“Show Debug Info”

Thanks for the recommendation to install the Debian package.

1 Like

Debug info:

Obsidian version: v1.4.5
Installer version: v1.4.5
Operating system: #32~22.04.1-Ubuntu SMP PREEMPT_DYNAMIC Fri Aug 18 10:40:13 UTC 2 6.2.0-32-generic
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on


Obsidian saves every few seconds but if you closed Obsidian immediately after making a change it’s possible to lose those last few seconds of writing.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.