Lost All My Settings On The Graph View!

Hi all!

I love this community and it’s my first post ever, so it sucks it has to be on the help section, but here it goes:

I was using my vault normally when suddenly I noticed my graph view was all gray, all my Group colors and my filters where gone. It essentially restored to default settings, but I never clicked it! Interestingly, the local graph view did retain the settings, so I will be able to copy them manually to the big graph view. (Though actually, it saved like an older version of my settings, because I had already fixed some tags and added a new group color, and that doesn’t show on the local graph either. So it’s like it went back to an old back-up or something? Strange.)

Things I have tried

  1. I tried restarting Obsidian, but it didn’t help.
  2. I also tried disabling the Workspaces core plugin, since I read somewhere it didn’t save graph settings? But I had enabled it a few days ago and I had used the graph view with it, so I’m not sure that’s the case. At any case, it didn’t help. I also restarted Obsidian once again.
  3. I also have another vault, and opened that one, but I don’t have any settings on that graph view to compare to.

What I’m trying to do

It would be great if I could restore my settings (like i’m secretly hoping it’s saved somewhere and I just have to click a button to restore it, lol), but if not, I’m wondering what happened and how to prevent this from happening again? Though I know it won’t be easy to guess just from this post. But maybe someone else went through something similar?


Normal Graph View with Settings:

Gray Graph View without Settings:

Local Graph View:
Help Forum - Local-graph

:confused: Anyone else had this problem?


This won’t help you now, unless you have your vault backed up somewhere, …

for the future …

In your vault in your file explorer there is a folder called:


… depending on your file system you may have to enable "show hidden files’ to see it.

In that folder the file …


has all your graph settings.

When happy with your settings copy & paste that file somewhere safe so that you can paste it back in should you ever lose your settings again.

  1. What OS?
  2. What version (and installer) of Obsidian?
  3. Are you using any syncing tools? Are you sure? Is your vault stored in a built-in OS folder that syncs. Check inside your .obsidian folder and look for any duplicate settings files. (Any files with numbers at the end, or “conflicted” or “duplicate” or “copy” in the name.)

Otherwise yeah, it’s highly recommended to backup your vault. I personally use git, and I make separate commits for my settings folder, and for my notes. So I can easily roll back settings if things go wrong with plugins, etc.

Thank you so much! I will do just that!

I actually have a back-up in an external drive but it’s like a month old, so that reminds me to do more frequent back-ups. :slight_smile:

Thanks again!

I’m using the latest version (updates automatically) on Windows 10.

I’m not syncing as I’m aware how that could screw up at any point while working with it. But I did do a back-up a while ago, so this is just a reminder that I have to back-up more frequently.

Thanks for your response and your suggestions!

The app updates, but the installer does not update automatically. And occasionally with a big Electron or CodeMirror upgrade, it is necessary to re-download from the website.

Just recently version v0.14.5 the release notes said we should install fresh from the website download.

(But I have no idea if that would even be related to your thread.)

1 Like

That’s actually good to know! I was also having another problem in which the PDF’s weren’t showing, and I read re-downloading might do the trick, but I thought the automatic updates would take care of that. Now I know.

Thanks again for your help! :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.