Longform - Projects and Scenes Disappear Following Sync

What I’m trying to do

Work with Longform (version 2.0.3) on PC and MacOS versions of Obsidian (1.4.14) with synchronised vaults. I am not using Obsidian Sync.

The problem

Following each sync, Longform appears lose connection with all projects and associated scenes. The files are still there, but they aren’t recognised in the Longform tab. This is normally remedied by simply restarting Obsidian - all the projects and scenes reappear in the Longform tab and then it functions again. But occasionally this fails to resolve the problem. If that happens the only solutions I have found are to either revert to a backup version of my vault, or to delete all index.md files and create new Longform folders, then copy the scenes from the old Longform Folders into the new ones while also deleting the .json file associated with the old Longform setup (a similar process was suggested for a similar problem here https://github.com/kevboh/longform/issues/17).

Restarting Obsidian did not resolve the problem today and the Longform tab shows this message.

I cannot find an option to mark folders as Longform projects as this message above suggests, but it is possible to create new longform projects in new folders.

I’m not sure why this happened today. Syncing had been working well for several weeks. I’m not sure if it is significant that there was an Obsidian update (to 1.4.14) in between sync operations, but Longform is now working on version 1.4.14 with my vault.

Aside from this issue, Longform is a brilliant plugin and I am grateful to the dev for all the hard work in producing it. It would be great if anyone has any ideas about what might be going wrong and how to prevent it from happening.

Further background

I was experiencing this problem frequently when using SyncThing. It creates conflict files when files have been modified on both sides and I believed that this was causing Longform to identify one of the conflict files as an additional ‘index’ file based the YAML data. These conflicts files might have been generated because of attempts to automatically synchronise. Having moved to use different synchronisation software, the problem seemed to have been resolved (a restart was always required following each sync, but afterwards everything functioned correctly).

Things I have tried

I have looked at the developer tab in Obsidian and have noticed that an error is thrown when obsidian loads.

My guess is that Longform is unable to find files it expects for some reason. I have looked at the .json file created by Longform for the ‘sessions’ and the .json file in the plugin directory in the /.obsidian directory. The relative file paths specified in the json files appear to match the relevant files. There are no special characters in the filenames.

Thanks,

Tom

Anything seem similar on their GitHub issue page?

Thanks ariehen,

None of the issues on the github page seem to be quite the same as the one I’ve got. I think the nearest one is this:

That issue was based on an older version of the plugin, but the advice from the dev was helpful. I’d just prefer to avoid the problem from happening if possible!

Unfortunately I’m not exactly sure how to reproduce the issue I’m having or exactly what is causing it.

It might be worth posting a detailed issue report over there after you poke around a bit more.

Longform isn’t exactly an obscure plugin, but maybe in combination with SyncThing it’s creating this unique issue?

Hopefully someone can offer some assistance! :seal:

I have the same issue. I’m hesitant to even use the plugin until this is resolved.

I’m experiencing the same or similar problem. I use the official Sync service for syncing.

Last night I renamed some of my files on my laptop. This morning on my desktop after syncing it said it found new files, should I add them as scenes? This has happened before, and I usually add them then have to drag them to the right order again. This time I thought I would try restarting Obsidian to see if that would fix it. It made it worse.

The Project tab no longer lists the draft I was working on. I tried adding a draft with an identical name, something that’s worked with this issue in the past, but it’s doing something very strange. If the draft already exists then it switches projects to a completely different project. When I go back to the correct project the draft still isn’t there.

This has happened to me a few times.

I seem to have just fixed this. I made a backup and started removing index files from old versions of longform. Then I opened the proper index and noticed it had two lines that seemed to be out of place:

-Intro-01
-Intro-02

Those were the last part of two files I had edited the night before on my other machine. One of them I’d renamed, and the other I added. The first part of the file name was missing and they weren’t indented along with the other files on the list. I don’t know how what happened.

I’m posting this in case it helps with bug fixes or others who are having the same problem.

Same problem here: two Macs, sync of files in iCloud. Longform projects keep disappearing, without any obvious reason. It works ok for 2 hours on my main Mac, then I do something with the other Mac and the project disappears in the main Mac. In this situation, this plugin is really difficult to use. Same error as Tomtastic:

Searching around, I have the same issue.

After sync from PC to iOS all projects have disappeared, no projects and no scenes remain.

After spending a long time importing all my projects from Scrivener and organising, this is pretty galling, so I’m going to refrain from using it until there’s a fix, it seems to have been happening for around three months.

There are several threads on it here too: Problems with Sync between MacOs and iOs · Issue #220 · kevboh/longform · GitHub

As a follow up I tried uninstalling and reinstalling Longform, made a new project and you don’t actually need to sync for it to lose projects and scenes,

The moment I closed and opened Obsidian again, everything was gone.