Login with 2FA

I enabled 2FA on my Obsidian account online. After I did that, I could not login through my Obsidian on the desktop. When I disabled 2FA in my online account, I could log in with no trouble. I would like to be able to use 2FA since I want to sign up for more Obsidian features but I would like this 2FA feature to allow me to login through the desktop.

  • Obsidian accounts now support two-factor authentication. To enable, go to your account settings at obsidian.md/account. Make sure you’ve installed the v1.4.5 Insider build before enabling 2FA on your account to avoid getting locked out.

Yes I know Obsidian supports 2FA. In my post, I said I enabled it. I use it online to log in to Obsidian. But on my desktop, after I enable 2FA, I cannot login to Obsidian through the desktop Obsidian program. When I disable 2FA, I can log in through Obsidian on my desktop.


and what is the desktop version you are using?


File a bug report in the bug report section and make sure you follow the BR template and the troubleshooting guide.

I will. Thank you so much, WhiteNoise, for reading and replying to my post.


I think I will let this go. I went over to troubleshooting and thought about testing this again-enabling 2FA, and consider it too much of a risk to get locked out of my account if things go wrong. I have a good long password, so I think I will live without 2FA.

I don’t think you can get locked out of your account since you can disable it in the browser. I am not quite sure why it’s not working for you. I would suggest you try again.

Yes, you are right. It does work in the browser, okay. It is just not working going through the app. Okay, I will try tomorrow or Sunday again and see if I get the same symptoms. It said something about a “sandbox,” so I must find out how to do that. Thank you again. I think I might upgrade my Catalyst license to Vip. I want to support this great program even more.

are you sure that when you tried the first time you were running 1.4.5+?

Anyway, let me know

Oh, I overlooked that. I was not running 1.4.5 when I first did 2FA. Thank you for mentioning that. Okay, will try to get back to you on Saturday or Sunday after I try again.

I’ve checked with 1.4.5 and for me, 2FA works on Desktop.

For reference: If you have trouble with Android, update through Google Play Store and check whether you have version 1.4.9 (108) (API v1.3.7). That’s the latest update per today, and 2FA works for me there. I had to update from 1.4.6 (that’s how I ended up in this topic :slight_smile: )

1 Like

Thank you, Jolie, for your comment! I am sure many people coming here will appreciate you writing the information. Thank you for checking it.

To WhiteNoise,

I enabled it again with 2FA, and it worked perfectly. I am thankful for all your help. I am sure I will be talking to you in the future. Thanks again for now.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.