Loading Vault runaway

Steps to reproduce

Expected result

Actual result

Environment

  • Operating system:
  • Obsidian version:

Additional information

First attempt to use Obsidian on a Mac. I clicked the first option on the initial screen. I’m locked into a “Loading vault …” operation with no way to stop it.

Unless someone here knows how.

@tipton I’ve moved this to the bug reports category, could you please fill out the template so we can try and reproduce this?

Steps to reproduce: I downloaded the app to my Mac. Installed it to the Applications directory. Started it up, and selected the first option on the intro screen. I think it said “make a vault” or something like that. I have closed the app multiple time, but every time I reinstall and restart, the “Loading vault …” process resumes. I have tried deleting the Obsidian app and the .obsidian subdirectory in my home directory, yet when I restart, the process resumes. I also tried deleting app and .obsidian directory, then restarting the Mac. Still no joy.

I tried hitting “Reload” on the “View” menu, and the following message comes up:
EPERM: operation not permitted, scandir ‘[directory name]’. It is stepping through the subdirectories of my home directory, so I now think it is loading my entire home directory - which may be hundreds of thousands of files and multiple hundreds of gigabytes.

Expected Result: I just expected to get a menu option or some sort of organizational screen

Actual result: Unstoppable load process - unless you have a solution for me.

Environment: MacOS Mojave 10.14.6 - Obsidian - 0.9.4

Quit the app, then delete the folder at /Users/YourUser/Library/Application Support/obsidian/ This should reset the app back to the starter page.

From the sounds of it, you probably chose your entire home directory to be “the vault” folder.

It worked!

Many thanks.

I just checked and my load from yesterday was still running (over 24 hours). Killed it. deleted the .obsidian directory from home directory and the entry you named from the [user]/Library/Application Support directory. Restarted - and I have the initial screen.

My suggestion is that the top choice “Open folder as vault” be made secondary to “Create new vault”. In the alternative do some sort of reality check before launching into a one-day-plus vault creation.

Looking forward to getting to try this out now.

BTW, does the same thing happen on other OSes?

uh…sorry.
I’m a student from Taiwan.
and my English is very bad.

I just want to say that when I open this app.
and it will just loading vault and I think is the same question just like the article on the top.
but I’m using Windows.
How can I do?

Operating system: Windows 10
Obsidian version: Obsidian 0.10.6

fell sorry about my poor English…

this is the directory for windows C:\Users\username\AppData\Roaming\obsidian

It works.
And thanks for replying so fast.
Have a good day:)

Hi there! Thanks for offering this solution :slight_smile: I’ having the same problem but I’m not able to find obsidian under ‘Application Support’.

My error message said: ENOENT: no such file or directory, stat '/Users/[mydirectoryname]/Documents/AY20:21 Sem 1/ GL4889B/Syllabus… till the name of a document.

Environment: MacOS BigSur 11.1 - Obsidian - 0.10.6

Thank you so much in advance!