Live Preview: not working, despite resetting editor mode, disabling plugins etc

Steps to reproduce

Using the editor, set to live-preview, however, I stil get the Edit / Viewing behaviour, and toggling live-preview doesn’t do anything, either.

Expected result

Using editor in live-preview mode.

Actual result

it is all configured for live-preview, but it operates in the legacy mode.


  • Debug info:
    Obsidian version: v0.13.23
    Installer version: v0.13.23
    Operating system: Windows 10 Enterprise 10.0.19044
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: Sanctum
    Snippets enabled: 1
    Safe mode: on

Custom theme: for cosmetic issues, please first try updating your theme to latest. If still not fixed, please try to make the issue happen in the help vault or disable community theme and snippets.

Additional information

The issue does not occur in the Help vault, as this test was advised in another bug report. Toggling legacy mode on/off and rebooting obsidian does also not help.

what happens if close all the panes and open a new one?

Thanks for the reply.

Depends on the note. Some notes will work in live-preview, others won’t. Haven’t been able to discern a pattern, which will work or won’t work.

Please, post a screen recording of this happing in the help vault.

Is there a way to “reset” Obsidian, as in cleaning a browser? I know and tried (see above) to re-enable safe-mode for plugins, but this doesn’t resolve the issue. In the help-vault I have no issue, so I’m thinking it must be something related to what I did in modding Obsidian, that isn’t resolved through safe-mode-ing plugins.

Done some more testing. Deleting everything from my Vault’s .obsidian folder did not restore functionality for existing note files.

Newly created notes did have the desired toggle-behaviour for live-preview though.

This indicates to me something in the metadata of the existing notes must be wrong, maybe through some plugin influence? Is that feasible? I’m looking into it now.

EDIT: Okay, it is related to the yaml front matter. When copying frontmatter from docs it immediately starts working again. When using my templated frontmatter, it doesnt. Limiting it down, it’s the dashes

that cause the issue. Really strange, my — work for

style lines, why wouldn’t they work for frontmatter syntax. Either way, I’ll stop investigating this now.

Found the problem after all. There was one SPACE after the final delimiting dash. My yaml was sth like:

yaml content

and that crahsed the parsing of everything after that.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.