Live Preview: Embed Block Reference not render properly inside a list

We strongly recommend you to search the forum with possible keywords before submitting a new bug report. Please also try your repro steps with third-party plugins and custom CSS disabled and see if it’s still reproducible. If it’s an issue with third-party plugins or themes, try contacting the author for help. Once you’ve done the above, delete this line.

Steps to reproduce

Enable Live Preview mode. Set current view to editing.

Consider two files.

This is the content of file Test

- [[Example]]
	- ![[Example#^e845f0]]
	- ![[Example#^5702a7]]

This is the content of file Example

Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. ^e845f0

Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. ^5702a7

Expected result

See Actual result

Actual result

There is an empty line above the embedded block.


  • Operating system:
  • Debug info:

Obsidian version: v1.0.3
Installer version: v0.15.9
Operating system: Darwin Kernel Version 21.6.0: Thu Sep 29 20:12:57 PDT 2022; root:xnu-8020.240.7~1/RELEASE_X86_64 21.6.0
Login status: logged in
Catalyst license: vip
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: light
Community theme: none
Snippets enabled: 3
Restricted mode: off
Plugins installed: 34
Plugins enabled: 31
1: Admonition v9.0.3
2: Advanced Tables v0.17.3
3: Another Quick Switcher v4.4.0
4: Better PDF Plugin v1.3.0
5: Clear Unused Images v1.0.6
6: Copy button for code blocks (fixed version manifest) v0.2.1
7: Dataview v0.4.26
8: Excalidraw v1.6.28
9: Vale v0.9.0
10: Templater v1.11.3
11: Tag Wrangler v0.5.2
12: Supercharged Links v0.6.8
13: Style Settings v0.4.10
14: Readwise Official v2.0.1
15: Media Extended v2.11.1
16: Highlightr v1.2.1
17: Link Favicons v1.7.3
18: Media Extended BiliBili Plugin v0.3.1
19: QuickAdd v0.5.5
20: Ozan’s Image in Editor Plugin v2.1.1
21: Obsidian Github v1.0.1
22: Obsidian Git v2.4.1
23: DB Folder v2.7.1
24: Juggl v1.4.0
25: Recent Files v1.3.3
26: Breadcrumbs v3.6.3
27: Vault Changelog v0.1.0
28: Shell commands v0.16.0
29: Matter v1.1.3
30: Note Refactor v1.7.1
31: Outliner v4.1.0

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

This is not a bug. It’s how it currently works. Search/open a FR.