Lists are unfolded if an unrelated checkbox is checked while the cursor is still inside

Steps to reproduce

  • Create a list, then fold it.
  • Check a checkbox that is outside of the list while the cursor is still inside the folded list.

Did you follow the troubleshooting guide? [Y/N]

Yes. This bug is present when using the sandbox vault in the latest v1.5.8 update.

Expected result

The folded list should remain folded.

Actual result

The folded list is unfolded, causing the entire page to be shifted down, sometimes a significant amount depending on the length of the list.


Obsidian version: v1.5.8
Installer version: v1.4.13
Operating system: Windows 10 Pro 10.0.19045
Login status: not logged in
Insider build toggle: off
Live preview: on
Base theme: adapt to system
Community theme: none
Snippets enabled: 3
Restricted mode: off
Plugins installed: 24
Plugins enabled: 24
1: Linter v1.22.0
2: Emoji Shortcodes v2.2.0
3: Recent Files v1.3.9
4: Advanced Tables v0.20.0
5: Dynamic Table of Contents v0.0.27
6: Dataview v0.5.64
7: Regex Find/Replace v1.2.0
8: Better Word Count v0.10.0
9: Garble Text v1.2.0
10: Numerals v1.2.0
11: Typewriter Scroll v0.2.2
12: Scroll Offset v1.0.4
13: Commander v0.5.1
14: Reading Time v1.1.1
15: Janitor v1.0.7
16: Dynamic Highlights v0.3.1
17: Quick Switcher++ v3.3.9
18: Dictionary v2.22.0
19: Settings Search v1.3.10
20: Annotator v0.2.11
21: Chem v0.3.0
22: Pseudocode v1.5.4
23: TikZJax v0.5.1
24: Templater v2.1.0

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

After some testing, I found that this behaviour is not present in v1.5.3. I have not tested versions earlier than that, however, despite using Obsidian for almost two years, I have never noticed this behaviour, so I assume it is new to the v1.5.8 update.

Also, please see this previous bug report which is similar.

Please see the attached screen recordings. The one with the black background is v1.5.8. The white background is v1.5.3. The behaviour of v1.5.3 is what I expected to happen.



1 Like

I haven’t had a chance to try a previous version on desktop yet, but I see the same behavior using desktop Obsidian v1.5.11.

I did check using iPadOS v17.4 in a new vault:

  • Obsidian v1.4.17 (115) - no unexpected unfolding of lists when clicking checkboxes anywhere in Live Preview.
  • Obsidian v1.5.4+ (118) - unexpected unfolding of a list where the cursor last was when clicking in another list in Live Preview.

Also related to this post: Nested lists unfold when pasting in the line above - #4 by dogshift

I think “checking” a checkbox uses the same copy+paste function under the hood. I’m seeing the same random unfolding behavior when I paste text ABOVE any folded list.

Additionally, and possibly related-ly, clicking on a link in live preview now puts the cursor into the link, which shows you the markdown formatting of the link. This didn’t use to happen before. In order to put the cursor onto the line of a link, you had to click elsewhere on the line. Is this intended behavior?


will be fixed 1.5.13

Still open!

will be fixed 1.6.1

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.